SOLVED

Embedded Forms Not Working Properly for Cookied Users

Go to solution
Chris_Wilcox
Level 9 - Champion

Embedded Forms Not Working Properly for Cookied Users

Hi Everyone,

I have a ticket in with Marketo about this issue, but thought maybe someone in the community has had this issue and knows how to resolve.

We have some landing pages we created for a campaign with gated content behind an embedded Marketo form. Smart Campaigns are sending an automated follow up email upon all form fills, but the emails are not consistently triggering.

  1. New users (previously not cookied) - Form completions are triggering the smart campaign as expected
  2. Returning Users (cookied) - Form completions are not being captured in any activity log on the contact record, or in the smart campaign itself.
  3. Incognito Window, but submitting known email address: Works as expected, smart campaign triggers correctly.

In other words, if I go to the page and put in my own email, nothing happens on the back end. But if I go to the page in an incognito window and submit that same email address, it works as expected.

No idea what's causing this, the smart campaigns are "Fills Out Form" with no filters applied, users are set to qualify "every time," so all form fills should be triggering the follow up.

Thanks!

Edit: I tried this on a Marketo-hosted landing page and it works as expected in all scenarios. Only Embedded forms for known users is it not working correctly!

1 ACCEPTED SOLUTION

Accepted Solutions
SanfordWhiteman
Level 10 - Community Moderator

Re: Embedded Forms Not Working Properly for Cookied Users

Yep, I'm beginning to hone in on it.

In the embed code, please swap in pages.hartfordfunds.com in both places that app-sj08.marketo.com currently appears. Then test again in Chrome 72.

View solution in original post

15 REPLIES 15
SanfordWhiteman
Level 10 - Community Moderator

Re: Embedded Forms Not Working Properly for Cookied Users

Supply your URL.

I doubt that nothing is happening "on the back end" with data there to act on. Question is whether the forms endpoint receives data from the front end at all.

Chris_Wilcox
Level 9 - Champion

Re: Embedded Forms Not Working Properly for Cookied Users

Here's an example URL with the embedded form: https://www.hartfordfunds.com/ad/BearMarkets.html

Here's the same form asset hosted on a marketo LP: https://pages.hartfordfunds.com/Advertising-2019_01307226-test-page.html

Note - we have custom java that keeps the user on page and displays a download button upon successful submission of the form. Maybe that's getting in the way, but it's never been an issue and we've used this method countless times in the past.

SanfordWhiteman
Level 10 - Community Moderator

Re: Embedded Forms Not Working Properly for Cookied Users

Please let me know the exact browser version and OS version with which you can consistently reproduce this.

Also, how many form submissions do you have for the lead teknkl+test0002@email.invalid? I submitted the form twice, first from an originally anonymous Munchkin session and again after that session was associated.

Chris_Wilcox
Level 9 - Champion

Re: Embedded Forms Not Working Properly for Cookied Users

I'm using Chrome Version 72.0.3626.119 on Windows 10 Enterprise (v1703)

Here's a screenshot of the activity log:

marketo-form-fill.jpg

Marketo got back to me -- Recommended me dropping my cookies for the page and retrying. Once I deleted my cookies, the first time I filled out the form using my email, the form submission was successful. When I returned and resubmitted, subsequent submissions failed to properly log in Marketo.

I also tried this in Firefox (65.0.2 (32-bit)) and it consistently works as expected regardless of cookie scenario in Firefox.

SanfordWhiteman
Level 10 - Community Moderator

Re: Embedded Forms Not Working Properly for Cookied Users

And how many submissions from my test email?

Chris_Wilcox
Level 9 - Champion

Re: Embedded Forms Not Working Properly for Cookied Users

teknkl+test0002@email.invalid

I see 2 submissions (most recent submissions on the log I screenshotted). I also see 5 from test0001.

Thank you very much for taking a look!

Chris_Wilcox
Level 9 - Champion

Re: Embedded Forms Not Working Properly for Cookied Users

I see more submissions coming through, figured it'd be helpful to give another update:

5 from test0003

1 from test0004

2 from test0005

marketo-form-fill-2.jpg

SanfordWhiteman
Level 10 - Community Moderator

Re: Embedded Forms Not Working Properly for Cookied Users

Yep, I'm beginning to hone in on it.

In the embed code, please swap in pages.hartfordfunds.com in both places that app-sj08.marketo.com currently appears. Then test again in Chrome 72.

View solution in original post

Chris_Wilcox
Level 9 - Champion

Re: Embedded Forms Not Working Properly for Cookied Users

I will have to test that tomorrow, I don't have publishing rights in the CMS. I'll make the changes now and shoot a note to our web team to push the change live first thing.

Seriously appreciate you taking a look. I have been banging my head against a wall all day trying to figure it out.