SOLVED

Using a Token in the Follow-Up URL setting of a form no longer working?

Go to solution
Ilana_Guilfoyle
Level 2

Using a Token in the Follow-Up URL setting of a form no longer working?

Hello,

For a long time now I've been able to use a local token as the value for a form's follow-up URl setting. As of recently this will no longer validate:Screen Shot 2015-08-12 at 12.30.16 PM.png

I've also tried using the token at the form level (form defined) but that results in the page just reloading on form submit, instead of redirecting to the follow-up page. Is this something anyone else is experiencing/found a solution for (aside from having to manually choose for every landing page). Ideally, My team shouldn't have to be editing the form settings for every landing page they create.

Thanks!

Tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Justin_Cooperm2
Level 10

Re: Using a Token in the Follow-Up URL setting of a form no longer working?

We're aware of this issue and are going to be fixing this very soon. This broke because more stringent validation logic was added to the platform to avoid potential problem scenarios. This is an area that has historically allowed tokens to be used, but it's never been an "officially" supported feature. The reason for this is that there are several potential issues that customers may not have been aware of when using tokens in follow-up URLs. As we work on rolling out support again, we have made some improvements to solve some of the previous issues. That said, there are still some significant consequences that need to be understood (and we will add a note to the UI to indicate this):

  1. This will break if you are embedding the form on an external page.
  2. Only program tokens (my.token) will be allowed.
  3. This will break if you use a program token that isn't a "text" token.

ETA for rollout is ~3 weeks.

Justin

View solution in original post

18 REPLIES 18
Josh_Hill13
Level 10 - Champion Alumni

Re: Using a Token in the Follow-Up URL setting of a form no longer working?

What is the URL itself you are using? You cannot use "http://" in a token.

But that's probably not the issue here. Ask Support directly.

Ilana_Guilfoyle
Level 2

Re: Using a Token in the Follow-Up URL setting of a form no longer working?

Yeah, I've tried both with and without http, neither has worked.

Edward_Unthank_
Level 10

Re: Using a Token in the Follow-Up URL setting of a form no longer working?

Oh no!! I severely dislike this. This is core to the setup we've been using for all landing pages and forms, everywhere.

Marketo has been putting in more guard-rails to tokens behind the scene—about a month ago, they started throwing up error messages if you try to delete tokens that are used by program assets which is another example of a safety guard-rail at the expense of power users.

I don't know how to escalate this, or to whom we can escalate this. Any Marketo employees able to jump in and offer a solution?

Edward

SanfordWhiteman
Level 10 - Community Moderator

Re: Using a Token in the Follow-Up URL setting of a form no longer working?

In fairness, this can be accomplished using a token in the LP + the Forms 2.0 onSuccess event, no?

Ilana_Guilfoyle
Level 2

Re: Using a Token in the Follow-Up URL setting of a form no longer working?

Yes, i could write some custom onSuccess javascript, but that seems like a pretty large lift for something that was once super simple. And thats not a viable solution for teams that don't have a dedicated developer. Plus, there's this unanswered question I unearthed in these forums: Token encoding in Follow-Up URL

SanfordWhiteman
Level 10 - Community Moderator

Re: Using a Token in the Follow-Up URL setting of a form no longer working?

Just because they couldn't find an answer doesn't mean I can't.

Local Token:

pastedImage_1.png

HTML Block:

MktoForms2.whenReady(function(form){

  form.onSuccess(function(vals){
    document.location.href = "{{my.ThankYouURL}}";
    return false;
  });
});

Pop that HTML in your template or LP and you're good to go.

Not saying it's cool to take features away, but I think this one is fairly easy to work around.  As for needing a developer... well, often I wish people would think twice before copying-and-pasting something they don't understand, but the reality is that's how people work with JS (and CSS and HTML, for that matter) all the time!

Ilana_Guilfoyle
Level 2

Re: Using a Token in the Follow-Up URL setting of a form no longer working?

Edward Unthank , I'm very familiar with the work you've done with tokens and have used it as a basis for how we set up our landing page functionality.

The good news is that the tokens still do work on active programs. The bad news, as soon as your try to make any changes in the landing page editor, like change the form or update the token name in the follow-up field, you'll get the above validation error and be unable to save your edits or revert back.

I'll be filing a ticket and will let you all know the result.

Justin_Cooperm2
Level 10

Re: Using a Token in the Follow-Up URL setting of a form no longer working?

We're aware of this issue and are going to be fixing this very soon. This broke because more stringent validation logic was added to the platform to avoid potential problem scenarios. This is an area that has historically allowed tokens to be used, but it's never been an "officially" supported feature. The reason for this is that there are several potential issues that customers may not have been aware of when using tokens in follow-up URLs. As we work on rolling out support again, we have made some improvements to solve some of the previous issues. That said, there are still some significant consequences that need to be understood (and we will add a note to the UI to indicate this):

  1. This will break if you are embedding the form on an external page.
  2. Only program tokens (my.token) will be allowed.
  3. This will break if you use a program token that isn't a "text" token.

ETA for rollout is ~3 weeks.

Justin

View solution in original post

Ilana_Guilfoyle
Level 2

Re: Using a Token in the Follow-Up URL setting of a form no longer working?

Thanks! I really appreciate your quick response and explanation!