SOLVED

Smart Campaign Flow not Triggering even when all Conditions have Been Met

Go to solution
redleader
Level 1

Smart Campaign Flow not Triggering even when all Conditions have Been Met

Hi everyone, I'm running into a bit of an issue with a Smart List I created for an upcoming email campaign.

 

We are sending a marketing email to our existing leads/contacts. In this email, there is a link to a Marketo landing page, which has a few "Download Now" links, which point directly to a PDF file stored in our Design Studio. The thought process is that since we already have these contacts in our database, we don't need to gate the content with a formβ€”just link the buttons on the page directly to the PDF file.

 

So my Smart List trigger is incredibly simple, if the user clicks on a link containing "/230320_converging_technologies" ON that specific page, they should be added to the campaign and a "Thank You" email should be sent.

 

However, so far this flow/trigger has only succeeded for myself and one other co-worker. I have tested against nearly a dozen other internal email addresses, AND 3 external domain email addresses, none of which have worked.

 

I'm not sure why it worked for me, and one other, and not for anyone else... I'm suspecting browser, OS, AdBlock, etc, but I'm still relatively stumped. Should I add more steps to my trigger? Am I missing something critical? (screenshots below).

 

redleader_0-1679410361286.png

redleader_1-1679410449893.png

 

Thank you in advance (Likely MR. Whiteman πŸ˜‰ )

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Darshil_Shah1
Level 10 - Community Advisor

Re: Smart Campaign Flow not Triggering even when all Conditions have Been Met

I suspect that the people for whom you don't see activity in their respective act log accessed and clicked the link on webpage didn't have their Munchkin session associated with their person record in Marketo. I'd advise you to send an actual email using Send Email flow step while testing the trigger; activities from sample test emails sent from Marketo aren't logged, and hence, if people don't have a Munchkin-associated session from before, they won't get Clicked Link on Webpage activity logged in their activity log. 

 

Regarding, Add to Campaign step, you should check within your team to see whether you have an SFDC campaign with which you need to sync this Marketo program either using the native Program-Campaign sync or using Add to Campaign steps.

 

View solution in original post

7 REPLIES 7
amazonwebservic
Level 1

Re: Smart Campaign Flow not Triggering even when all Conditions have Been Met

Removed

Darshil_Shah1
Level 10 - Community Advisor

Re: Smart Campaign Flow not Triggering even when all Conditions have Been Met

Can you verify whether the Clicked Link on Web Page activity is present for the selected Web Page in the activity log of the people who didn't flow through the campaign? If you see the activity in the activity log and people didn't flow through the campaign, you could match the activity (Link Name and Web page specifically) with the activity of your person record (which as you said did flow through the campaign flow).

 

Also, I second @amazonwebservic's comment - you don't have an Add to Campaign step in your campaign's flow. Is that taken care by a different smart campaign or do you have a native Program-Campaign sync enabled so you only need to update the Marketo program status and people will get added to the SFDC campaign with the matching status?

 

Edit: On a second thought, I think you meant additions to the Marketo camapaign itself (i.e., the person should qualify and pass through the campaign). Usually, we use Adding to Camapaign phrase for adding to CRM campaigns.

 

redleader
Level 1

Re: Smart Campaign Flow not Triggering even when all Conditions have Been Met

Thank you for your response, I am now very deep in this rabbit hole...

 

For some of the contacts, yes, the "Clicked Link on Web Page" activity appears in their Activity Log, but, not for everyone who received a test email.

 

I have the Campaign set to trigger every time, not just once, just to be sure it's working (I will change this once I can confirm its functionality).

 

Regarding the "Add to Campaign" stepβ€”I'm not sure I need this but could be wrong. Our Marketo master left us last year and I have had to fill in for the time beingβ€”I am no expert. Here are a few more screens:

 

redleader_0-1679418355778.png

 

Darshil_Shah1
Level 10 - Community Advisor

Re: Smart Campaign Flow not Triggering even when all Conditions have Been Met

I suspect that the people for whom you don't see activity in their respective act log accessed and clicked the link on webpage didn't have their Munchkin session associated with their person record in Marketo. I'd advise you to send an actual email using Send Email flow step while testing the trigger; activities from sample test emails sent from Marketo aren't logged, and hence, if people don't have a Munchkin-associated session from before, they won't get Clicked Link on Webpage activity logged in their activity log. 

 

Regarding, Add to Campaign step, you should check within your team to see whether you have an SFDC campaign with which you need to sync this Marketo program either using the native Program-Campaign sync or using Add to Campaign steps.

 

redleader
Level 1

Re: Smart Campaign Flow not Triggering even when all Conditions have Been Met

Thank you, Darshil.

Hmm, so, for this campaign flow to work properly, do the contacts/leads need to already be a part of the existing Program? There is an active sync to Salesforce, as you can see in my screenshot below... but, there are not many members (we had another organic social campaign, with a form-fill landing page, prior to this email campaign).

 

I would assume that any existing contact/lead should technically be added to the new email campaign flow once the trigger conditions are met, but I could be wrong.

 

When you say send an actual email - do you mean for the initial test? For example, currently, I am right-clicking on the initial email for the campaign, selecting 'send sample', then manually entering addresses I know to be in our existing leads/contact records. This initial email shows up as a "TEST" in their inboxes, and actions taken on this email are not recorded. However, shouldn't subsequent/follow-up actions taken on the landing page (once they click the link in the email) be triggered? OR, is the Munchkin session not being carried across from the initial TEST? I really appreciate all the guidance, here..

 

 

redleader_0-1679425631993.png

 

Darshil_Shah1
Level 10 - Community Advisor

Re: Smart Campaign Flow not Triggering even when all Conditions have Been Met


@redleader wrote:

Thank you, Darshil.

Hmm, so, for this campaign flow to work properly, do the contacts/leads need to already be a part of the existing Program? There is an active sync to Salesforce, as you can see in my screenshot below... but, there are not many members (we had another organic social campaign, with a form-fill landing page, prior to this email campaign).

Nope, people need not already be members of the program; non-program members should flow through the campaign flow if they qualify for it. Cool, since you have a linked SFDC campaign, make sure you use the Change Program Status flow step in your campaigns so people get added to the SFDC campaign with the same status as well. Let us know if you have any questions here.

 


 

When you say send an actual email - do you mean for the initial test? For example, currently, I am right-clicking on the initial email for the campaign, selecting 'send sample', then manually entering addresses I know to be in our existing leads/contact records. This initial email shows up as a "TEST" in their inboxes, and actions taken on this email are not recorded. However, shouldn't subsequent/follow-up actions taken on the landing page (once they click the link in the email) be triggered? OR, is the Munchkin session not being carried across from the initial TEST? I really appreciate all the guidance, here..

I think this is where the trouble is! Instead of sending out the sample test emails using Send Sample option, try sending out emails with a real Send Email flow step. You could open a test person, Person Actions > Marketing > Send Email > Select Email in the Dialog > Run Now or create a campaign to send out emails. Either way is fine, you just need to ensure that you're using Send Email flow step for sending out the emails while testing. Once you receive the email, click the tracked link to the webpage, click the link to access the PDF, and check back in the person activity log whether you see the Visited Webpage and Clicked Link on a Web Page activity or not. Unlike the emails sent via the Send Email flow step, the Munchkin session doesn't get associated upon clicking the tracked links from the sample emails (re-tested now to verify). Let us know if you have questions.

Michael_Florin
Level 10

Re: Smart Campaign Flow not Triggering even when all Conditions have Been Met


I have tested against nearly a dozen other internal email addresses, AND 3 external domain email addresses, none of which have worked.

 


Do your test addresses have that Clicked Link on Web Page activity in their histories? If you are testing for various addresses on one computer, it can create a lot of cookie confusion, and if your Smart Campaign is set to Run Only Once, you probably can't trigger this campaign once again.

 

EDIT: Darshil was quicker. πŸ™‚