SOLVED

Progressive Profiling Not Working Within Specific Iframe

Go to solution
adamdavis
Level 1

Progressive Profiling Not Working Within Specific Iframe

I have a form that uses ProgPro brought into a page via an integration with this content creation platform (Ceros) that leverages an API to choose and populate the form.

 

When you publish the Ceros content, you get an iframe which you can embed on a page, so that's what I have here:

 

https://ceros.fun/progprotest.html

 

The form is inside the Ceros iframe.

 

The "Job Title" field should go away after the form is filled out and you reload the page.

ProgPro works fine when you view the Ceros page by itself here:

https://view.ceros.com/adam-davis/progressive

 

It's only when it's embedded on another page where it stops working.

 

NOTE: This is a test setup, so there is no other content on the 'parent' page where the iframe lives, so I hope people realize that and don't just say "Well, don't use the iframe then..."  😀 Typically the Ceros platform is used for microcontent or full-page interactive experiences, and sometimes there are forms in them like this.

 

It seems like when I place a Marketo form on a non-Ceros page and iframe-in that page, it works fine, and it's only within Ceros where this fails.

 

I haven't been able to spot why this isn't working, so hopefully someone can point me in the right direction, thanks!

1 ACCEPTED SOLUTION

Accepted Solutions
SanfordWhiteman
Level 10 - Community Moderator

Re: Progressive Profiling Not Working Within Specific Iframe


It seems like when I place a Marketo form on a non-Ceros page and iframe-in that page, it works fine, and it's only within Ceros where this fails.

More likely: when the IFRAME is embedded within a document from another domain it fails, because modern browsers won't send or set cookies in a 3rd-party context. (An IFRAME being the epitome of a 3rd-party context as it's an entire other document.)

 

ceros.fun and view.ceros.com don't share a common private domain.

View solution in original post

2 REPLIES 2
SanfordWhiteman
Level 10 - Community Moderator

Re: Progressive Profiling Not Working Within Specific Iframe


It seems like when I place a Marketo form on a non-Ceros page and iframe-in that page, it works fine, and it's only within Ceros where this fails.

More likely: when the IFRAME is embedded within a document from another domain it fails, because modern browsers won't send or set cookies in a 3rd-party context. (An IFRAME being the epitome of a 3rd-party context as it's an entire other document.)

 

ceros.fun and view.ceros.com don't share a common private domain.

View solution in original post

adamdavis
Level 1

Re: Progressive Profiling Not Working Within Specific Iframe

Thanks! We actually came to that same conclusion shortly after I posted this.

We also found that only fails in Chrome and I think Safari - it's fine in Firefox.

 

Also thanks for calling out that one line from my post.  My testing was flawed - I was iframing a page from the same domain, which of course will work fine.

 

Ceros does offer the option of using a "vanity domain" which is a subdomain, and that seems to resolve the issue!  

I've updated my test page to use "super.ceros.fun" as the domain.