{{member.webinar url}} issues

Anonymous
Not applicable

{{member.webinar url}} issues

Hi guys,

We've run about 20 webinars that have all successfully pulled a "Join Link" using the token: {{member.webinar url}}

Recently, we changed our template for the email that contains that link, but the {{member.webinar url}} code remains the same across both of them.

However, now the "Join Link" doesn't render anything at all -> no link, just the blank text "Join Link". Any idea why this would happen? How to fix?

Thanks,

Andrew

9 REPLIES 9
Josh_Hill13
Level 10 - Champion Alumni

Re: {{member.webinar url}} issues

Screenshot? Code?

It's possible you need a 1 min wait step after you set Program=Registered to allow the URL to fill in. But I suspect this is an HTML issue.

Anonymous
Not applicable

Re: {{member.webinar url}} issues

I put in a one-minute wait, and still didn't work.

I attached some screenshots. I've also copy/pasted our form code, as well as the relevant HTML from our template.

Here's the HTML (after I edited it / screwed it up

<p>Instructions for joining the Web Clinic (we'll send these out again on {{My.Date1}}):

<p>1. Click and join at the specified time and date: <a href={{member.webinar url}}>Join Link</a></p>  // this part is wrong for sure //

<p>2. Choose one of the following audio options:</p>

<p> TO USE YOUR COMPUTER'S AUDIO:</p>

<p> When the webinar begins, you will be connected to audio using your computer's microphone and speakers (VoIP). A headset is recommended.</p>

<p>--OR--</p>

<p>TO USE YOUR TELEPHONE: If you prefer to use your phone, you must select "Use Telephone" after joining the webinar and call in using the numbers below.</p>

<p>United States</p>

<p>Call-In Number: {{my.Call-In Number}}</p>

<p>Conference Call Number</p>

<p>Access Code: {{My.Access Code}}</p>

<p> Audio PIN: Shown after joining the webinar</p>

<p> Webinar ID:  {{my.WebinarID}}</p></p>

Here's our embedded form code:

<script src="//app-sj14.marketo.com/js/forms2/js/forms2.min.js"></script>

<form id="mktoForm_1102"></form>

<script>MktoForms2.loadForm("//app-sj14.marketo.com", "070-PTJ-534", 1102);</script>

Here are some screenshots of the setup:Screen Shot 2016-08-09 at 11.23.55 AM.pngScreen Shot 2016-08-09 at 11.24.31 AM.png

Anonymous
Not applicable

Re: {{member.webinar url}} issues

Also, just now when I tried to refresh from the webinar provider I got this error:

Refresh of 'Making the Business Case for SEO' failed

API Error: ERROR -> HTTP Code = '403'

This seems to be the culprit, any idea whats going on?


Andrew

Roxann_McGlump1
Community Manager

Re: {{member.webinar url}} issues

Hi Andrew,

The most common cause for the {{member.webinar url}} token to fail is that the webinar provider integration with Marketo is broken and is not passing back the URL back to Marketo.  Go into Admin > Launchpoint and check and see if you are getting 403 error.  If you are, do the following.

  1. Re-enter your webinar provider credentials.  You may have an expired password or some other connection issue.
  2. Go to your webinar program in Marketing Activities and refresh the webinar - Event Actions > Refresh from Webinar Provider
  3. Go into the Members tab of your webinar program and change the program status on any leads that have a status of "Registration Error" to Registered.
  4. Once you have everything updated, try the email again and see if the URL populates for the registered leads.
Renee
Level 3

Re: {{member.webinar url}} issues

I would like to check the error of registration as per your step 4. However, I could not find this filter in the smart list. 

Could you advise if I did anything wrong OR how I can set up this. 

Renee_0-1631771886716.png

 

Moreover, I set up a smart campaign to send the confirmation mail with member webinar URL token after the status is changed to registered. I would like to test whether the token was correctly populated. In the test, do I need to register as a lead in our database to fill out the form OR I can go the email asset to send a test email to myself. Could you advise, thanks. 

Amy_Goldfine
Level 10 - Community Advisor

Re: {{member.webinar url}} issues

Hi Renee, do you have a channel called "Invited"? The program status naming convention in the smart list is "channel > status" so I would expect to see "Webinar > Registration Error"

 

In order to test your registration flow you need to fill out the registration form.

Amy Goldfine
Marketo Champion & Adobe Community Advisor
Renee
Level 3

Re: {{member.webinar url}} issues

Yeah I found it. 

The registration form must be set up in Marketo right if I want to have member URL token, or I can still use event platform like go to webinar, ON24....

 

Moreover, 

Could you share me the practice for you to test whether the token works or not, (I am a new beginner, more detailed will be more useful), thanks. 

Lauren_Beth
Level 6

Re: {{member.webinar url}} issues

Andrew - this has happened to us several times, and again this week in fact, and always has to do with a sync failure with the webinar host (Webex) and Marketo.  Sometimes what Roxann McGlumphy mentioned above works but sometimes it doesn't.  We normally submit tickets to support immediately while we try to repair the sync just in case, as it has taken days to repair in the past. (We are moving away from Webex as a result). We ran some simple batches to fix the registration error. Smartlist = if program status is registration error. Flow  = change program status to not in program, 10 minute wait step, form filled out is X mark as registered, if filled out form is NOT x, mark as invited.

Alok_Ramsisaria
Level 10

Re: {{member.webinar url}} issues

There have been issues in Marketo and Webex lately. We have an open support case but still waiting for the issue to be resolved.