Hidden value on form not being passed correctly

Diane_Schmid
Level 3

Hidden value on form not being passed correctly

I have a hidden field on a form where the hidden value is true, yet when I fill out the form and look at my activity log under the form fill, it's marking that specific field as false.  Any idea why it's doing that?

8 REPLIES 8
Darrell_Alfons2
Level 10 - Champion

Re: Hidden value on form not being passed correctly

Hey Diane,

What field is it? Screen shot?

I'm thinking another campaign is changing the value, but hard to be sure.

Diane_Schmid
Level 3

Re: Hidden value on form not being passed correctly

Hi Darrell - it's a custom field for one of our e-letters.  I cloned an existing form that was set up the same way and then just swapped out the field name, but for some reason it's just not working. form.png

Darrell_Alfons2
Level 10 - Champion

Re: Hidden value on form not being passed correctly

If you look at the hidden field in the form, does it look like this?

pastedImage_0.png

Diane_Schmid
Level 3

Re: Hidden value on form not being passed correctly

Yep!

pastedImage_0.png

I've decided to add a "change data value" step to my flow as a work around as this campaign is launching tomorrow, and that worked correctly.

Darrell_Alfons2
Level 10 - Champion

Re: Hidden value on form not being passed correctly

ok, good idea. ya weird how that wasn't working. maybe someone else will know. good luck!

SanfordWhiteman
Level 10 - Community Moderator

Re: Hidden value on form not being passed correctly

Diane, what's happening is you have PreFill enabled for that field. Hence, when you have a session that's associated with a named lead, and that lead has subscriptionForbesCryptoConfidential set to false that value will override the default. This is the known order-of-operations w/PreFill and Hidden fields.

As you can see, this doesn't happen with a fresh anonymous session:

pastedImage_0.png

Diane_Schmid
Level 3

Re: Hidden value on form not being passed correctly

Thanks Sanford - this is exactly what Marketo support said as well!

SanfordWhiteman
Level 10 - Community Moderator

Re: Hidden value on form not being passed correctly

Can you mark my answer as Correct?