Summary
Marketo-only records must be manually synced, become a member of a default-program, encounter a Salesforce flow step in order to sync with Salesforce.
Issue
Records are in the Marketo database but are not syncing over to Salesforce automatically like I thought they would.
Solution
The sync between Marketo and Salesforce is bi-directional. However, in order for a record to be synced, one of the following conditions must be met:
- The record becomes a member of a program which is synced to a Salesforce campaign. This occurs when the background sync is used to keep members of a Salesforce campaign in sync with a Marketo Program status. This can easily be verified by navigating to the program and looking at the summary view. More information on this feature can be found here:
- The record encounters an SFDC flow step. Any time a record encounters a Salesforce related flow step in a smart campaign, this will cause the record to sync with Salesforce. Some of these flow steps have other implied actions, which you can read about here:
- The record is manually synced to Salesforce through a single-flow action. This is an intentional user action. It can only occur when you find the record in your database or in the people tab of a smart list and select the option from the 'Person Actions' menu. More on how to do this can be found in this document:
Root Cause
Records had not encountered SFDC flow steps, become members of a program synced with a Salesforce campaign and hat not been manually synced to Salesforce.
Environment
Marketo with the built-in integration with Salesforce