Re: 'Fail to retrieve sObject' and 'sync to marketo'

Darshil_Shah1
Level 10 - Community Advisor

Re: 'Fail to retrieve sObject' and 'sync to marketo'

Yeah, I meant SFDC! Thank you for confirming. I was talking about SFDC Type field, the field’s value is null for Marketo only records.

Best,
Darshil
dealpathnoah
Level 2

Re: 'Fail to retrieve sObject' and 'sync to marketo'

Gottcha, thanks! 
Should I just submit a support ticket at this point? Seems like we are going down the rabbit hole here. Thanks for all your help! 

Darshil_Shah1
Level 10 - Community Advisor

Re: 'Fail to retrieve sObject' and 'sync to marketo'

I'd guess so, as technically you should not see Merge activity for a lead that's created afresh after being deleted from Marketo. If by any chance you remember / can re-collect the original lead's lead-id (which you deleted from Marketo), is that same as the merge id on the merge activity detail on the newly created lead?

Best,
Darshil
dealpathnoah
Level 2

Re: 'Fail to retrieve sObject' and 'sync to marketo'

There is actually no details on the merge activity for the lead that references an ID.

dealpathnoah_0-1651692688426.png

I could re-create this scenario if we want to see if the SFDC id from the first record before it gets deleted out of marketo, matches the new one that gets created in marketo. 

Darshil_Shah1
Level 10 - Community Advisor

Re: 'Fail to retrieve sObject' and 'sync to marketo'

If the SFDC Id would have been updated by merge activity, it would have been visible in the Merge fields section, something like below:

Darshil_Shah1_0-1651693663489.png

The Merge Id in the activity snapshot shared by you depicts the losing record (the one that was merged with this record whose activity you're viewing, i.e., the winning record).

Best,
Darshil
dealpathnoah
Level 2

Re: 'Fail to retrieve sObject' and 'sync to marketo'

Ah I see, thanks! 
Should I re-create this scenario and mark down the SFDC ID of the original record that gets deleted out, and see if it matches the one that stays post-merge? 

Thanks!

 
 
Darshil_Shah1
Level 10 - Community Advisor

Re: 'Fail to retrieve sObject' and 'sync to marketo'

Do you happen to have any person partition apart from the Default partition and/or custom de-dupe rules setup in your instance?

 

I think re-creating this scenario may help to double check the issue you're facing, you may refer steps below to re-test this - 

 

1. Take a synced record (present in SFDC and Marketo) - ensure that you don't see any sync errors while syncing them.

2. If you have the custom sync rule set up, update the Sync to Marketo field to False.

3. Delete this record from Marketo only (note the lead id and SFDC Id of this record before).

4. Wait for a couple of minutes, ensure that the record is deleted and is not searchable / accessible from the All People system SL.

5. Fill out the form with same email id as the lead you just deleted from Marketo.

6. Check out the Activity log, do you still see Merge activity with field(s) getting updated? Ideally when a anonymous record enters. Marketo - only activities should get merged and not any of the field values.

7. If you see the Merge activity, check the Merge Id if it's same the lead id of the record you just deleted.

8. Check if you still see the SFDC ID in the Info page of the person profile even though you haven't synced this record with SFDC.

 

Hope this helps!

 

Best,
Darshil
dealpathnoah
Level 2

Re: 'Fail to retrieve sObject' and 'sync to marketo'

Hey Darshil,

For one, thank you so much for your time here! 

I followed your steps and did not see any merge person activity happening this time, however, I do see some of the same problems. 

 

Marketo record prior to deleting from marketo: Syncs fine with no errors.
Person ID: 1233754
SFDC ID: 00Q2M00001KHhw6UAD
Lead ID in salesforce: 00Q2M00001KHhw6UAD


Same email after deleting from marketo, but keeping in SFDC and second form fill in marketo: No sync, same error as before.
Person ID: 1233781
SFDC ID: 00Q2M00001KHkG9UAL

I can see that at the exact time I created the second record in marketo, the first record that was deleted from marketo but synced to salesforce and kept there, with the custom sync button in salesforce unchecked, preventing the sync between marketo and salesforce. Has this in the lead history...
 
5/5/2022 10:36 AM - Lead Merged -Marketo Sync - noahtestingforsfdc noahtestingforsfdc, "Our company name" 
**Note that "Our company name" is actually the same of our org I just did not want to list it here


Any ideas here? How is it getting an ID if its not syncing to salesforce? And how is it syncing enough to merge them? And if they are merging why are the IDs different? What could it be possibly merging with if thet ID it takes on does not exist for any lead of contact in salesforce when you search for it? 


Such a mystery to me! 

Darshil_Shah1
Level 10 - Community Advisor

Re: 'Fail to retrieve sObject' and 'sync to marketo'

Any ideas here? How is it getting an ID if its not syncing to salesforce? And how is it syncing enough to merge them? And if they are merging why are the IDs different? What could it be possibly merging with if thet ID it takes on does not exist for any lead of contact in salesforce when you search for it? 


Such a mystery to me! 


Well, indeed this is strange! You say the record hasn't synced to SFDC, can you confirm below things:

1. The SFDC Type of the new record in Marketo is Empty (you can find this system managed field in the info page of the person profile), and 

2. There's no Sync Person to SFDC activity in the new person's activity log (new records should not sync to SFDC on its own and should remain in Marketo only, but won't hurt to eye over the person activities.

 


 
5/5/2022 10:36 AM - Lead Merged -Marketo Sync - noahtestingforsfdc noahtestingforsfdc, "Our company name" 
**Note that "Our company name" is actually the same of our org I just did not want to list it here


Well, AFAIK when a deleted synced person re-enters Marketo, a duplicate record gets created in SFDC - but seems like that's not happening, and instead you're seeing the SFDC ID on the new record in Marketo for which there isn't any record in SFDC (as per your description) and due to this you're seeing an error while trying to sync this record with SFDC, this isn't the expected behavior while  using the native SFDC sync with custom sync filter set up (properly). 😞

 

Best,
Darshil
dealpathnoah
Level 2

Re: 'Fail to retrieve sObject' and 'sync to marketo'

Thanks for all the help here! 
1. The SFDC type is not empty. Lead

2. It does try to sync with Salesforce upon creation, but the activity history shows. 
"Sfdc lead created but sync failed: Fail to retrieve sObject 00Q2M00001KHkG9UAL, this sObject could has been deleted or a permission setting is preventing sync user to read this record."

While it says "Sfdc lead created" there is no new lead in salesforce. And it does not match the old record in terms of ID