SOLVED

CO failure due to multiple records

Go to solution
vijayanandpaul
Level 2

CO failure due to multiple records

Hello Experts,

While syncing Custom Objects (COs) to Marketo , I am seeing that some records have errored with the following error,

 

"Found more than one Company with id18"

 

I was trying to query the Marketo companies object ("/rest/v1/companies.json?") but it gives me this error,

 

"Company API disabled"

 

Reason for me querying the companies object is because I want to check if really there are more than once companies that are present in Marketo for that particular id18 field. Can you let me know how I can cross check the error message to make sure Marketo is returning the correct error. I need to know this information to address the root cause of my sync failures.

 

Thanks,

Paul.

1 ACCEPTED SOLUTION

Accepted Solutions
Michael_Florin
Level 9

Re: CO failure due to multiple records

Hi Paul,

 

I fear you can't use "Account ID" as the link field. Marketo documentation states that you have to use the Marketo Company ID. More on this here: https://nation.marketo.com/t5/Product-Discussions/Custom-Object-Linked-to-Company/m-p/302133#M170135...- where I ran into the same issue.

View solution in original post

5 REPLIES 5
vijayanandpaul
Level 2

Re: CO failure due to multiple records

Just to provide the CO constraints, here it is,

vijayanandpaul_0-1617738446075.png

 

SanfordWhiteman
Level 10 - Community Moderator

Re: CO failure due to multiple records

Is this an SFDC-linked instance?
vijayanandpaul
Level 2

Re: CO failure due to multiple records

Yes, it is SFDC linked.

SanfordWhiteman
Level 10 - Community Moderator

Re: CO failure due to multiple records

Company API is disabled in that case.
Michael_Florin
Level 9

Re: CO failure due to multiple records

Hi Paul,

 

I fear you can't use "Account ID" as the link field. Marketo documentation states that you have to use the Marketo Company ID. More on this here: https://nation.marketo.com/t5/Product-Discussions/Custom-Object-Linked-to-Company/m-p/302133#M170135...- where I ran into the same issue.

View solution in original post