Tokens and HTML Formating in Emails

Anonymous
Not applicable

Tokens and HTML Formating in Emails

Hi Marketo Users,

I am putting together emails in Marketo using rich text tokens. The emails come out fine on desktop browsers but on mobile the images come out skewed. I am guessing this is because the HTML is not being updated as formatted in the token. Does anyone know of a good solution for using tokens and ensuring good formatting on mobile/desktop?

Thanks!

4 REPLIES 4
Josh_Hill13
Level 10 - Champion Alumni

Re: Tokens and HTML Formating in Emails

Perhaps the best way is to use a Text token and let it take on the formatting of the email. But that might not work so well if you are relying on the RT token for varied formatting or images.

Perhaps there is a DIV tag hack?

Anonymous
Not applicable

Re: Tokens and HTML Formating in Emails

Hi Josh,

It makes sense to go that route. Unfortunately, I am relying a bit on RT for formatting and as well as images so might not work for me. I will look into DIV tag hack.

Thank you!

Courtney_Grimes
Level 10

Re: Tokens and HTML Formating in Emails

Hi Jodie,

My educated guess (based on not seeing the token at all) is that it has less to do with the token and more to do with the actual code that's inside the token. On a technical level, all the token does is say "where you say {{my.thing}}, paste in the code inside {{my.thing}}." Marketo then renders the final email file that's delivered. As such, everything that's in that token is going to be the same no matter what.

With that said: are you using the new email editor or the old one (old one strips some newer features for targeting mobile devices)? Have you used a tool like Litmus to confirm this happens consistently on mobile devices versus one client like Apple Mail or Gmail for Android? Are you using any High-DPI targeting for the images? There could be a lot at play.

Anonymous
Not applicable

Re: Tokens and HTML Formating in Emails

Hi Courtney,

I am using the new email editor and not any High DPI targeting. It does seem like the issue is occurring on all devices from our check but definitely would be worth it to check out tools like Litmus. Thank you for your insight.