Re: Problem with Lead.First Name Token in an email Preheader

Cecile_Maindron
Level 10

Re: Problem with Lead.First Name Token in an email Preheader

"The only thing that isn't supported at the moment is using any token in the Marketo Preheader field." Justin Cooperman​ I'm surprised by your comment because we are using a program token (asset name) in our pre-header and it's working fine. I haven't seen yet any occurence where it wasn't working.... or did you mean it doesn't work if you try to pull a field value?

Grégoire_Miche2
Level 10

Re: Problem with Lead.First Name Token in an email Preheader

Bonjour Cécile,

The Preheader Justin is talking about is the one accessible in the email settings, not a potential "preheader" section or module in your email. Are you talking about the same thing ?

Vote here :

-Greg

Cecile_Maindron
Level 10

Re: Problem with Lead.First Name Token in an email Preheader

Grégoire, I'm talking about the pre-header feature (tick box with the 80 character limit)

Grégoire_Miche2
Level 10

Re: Problem with Lead.First Name Token in an email Preheader

Then only the {{my tokens work there.

-Greg

Justin_Cooperm2
Level 10

Re: Problem with Lead.First Name Token in an email Preheader

Hi, yes, I am referring to non-program tokens being used in the Marketo Preheader field as shown here Email Editor v2.0 Overview - Marketo Docs - Product Documentation

Thanks,

Justin

Carl_Delafonta2
Level 2

Re: Problem with Lead.First Name Token in an email Preheader

Hello Justin Cooperman​,

I was wondering if you got the chance to look at this issue ? I never really got a proper response from Marketo Support, as no one was able to reproduced it. However, Scott, who replied to this case, also experienced this problem with the lead first name token.

Thanks!

Carl

Dan_Stevens_
Level 10 - Champion Alumni

Re: Problem with Lead.First Name Token in an email Preheader

According to this thread ( ), there's been an enhancement ticket open since last May.

Justin_Cooperm2
Level 10

Re: Problem with Lead.First Name Token in an email Preheader

Hi Carl,

I'm referring to the Marketo Preheader field shown here in the Email Settings dialog. It will not support lead tokens at this time. As said before, tokens will work anywhere in the body of the email itself (and some customers may have their own preheader field in the body of the email...)

Email Editor v2.0 Overview - Marketo Docs - Product Documentation

Thanks,

Justin

Denise_Greenb12
Level 7

Re: Problem with Lead.First Name Token in an email Preheader

Hi Justin,

Would it make sense to have Marketo generate and error message if someone puts a token in the pre-header area - or if that's too hard - add hint text warning people it isn't supported? I've never tried to do this myself but reading through the thread, this seems like one of those areas that could very easily be overlooked (because you can't tell when you send a sample as opposed to a real email). It's so easy to implement the preheader (kudos to you for that) that it may not occur to people to read through the documentation. Plus if you have an email where the top of the email is a salutation with a first name token, when you check the box to enable the preheader, the preheader is autopopulated with the salutation - including the token - which A) doesn't populate correctly and B) gives people the misleading impression that tokens work in the preheader. Again - nothing to trigger a documentation check.

Denise

Jon_Wright
Level 4

Re: Problem with Lead.First Name Token in an email Preheader

Agree with these points. Also given that we've used program tokens in the pre-header without a problem (at least that we know of) we assumed that tokens worked, and didn't see any need to prove otherwise. The fact that it can display a completely different value and not the default value surely means there should be a more prominent way of preventing people using this.