Re: Marketo Integration SFDC Owner

Not applicable

Marketo Integration SFDC Owner

Hi all,

We have recently noticed a number of our MQLs not opening in SFDC due to a lead owner already being assigned. The lead owner is listed as 'Marketo Integration'. We haven't seen this before and there is no SFDC Workflow to allow for this. I have spoken to Marketo Support and they say that this assignment is happening in SFDC. Our SFDC admin, however has no idea where it is coming from and we haven't changed any of our processes. This is a big issue for us as SFDC won't allow our leads to MQL because it is assuming they are already being worked due to the Lead Owner being already assigned. I'm wondering if anyone else has seen anything like this and if you have a solution or work-around that's worked for you? Thank you!

Level 10 - Champion Alumni

Re: Marketo Integration SFDC Owner

You should look at your LARs more closely and the logs of the leads in Marketo. This is happening for a reason, probably due to

  • Marketo User Permission error
  • LARs were changed or broken due to other changes like Users or Queues leaving
  • someone change the sync flow steps or Change Owner.
  • possible that someone is Syncing a Contact to a Queue and creating a dupe...not sure that's the case here.

Your admin should be able to do more back tracking, so press them on this.

Do some tests with test leads to see what happens and when.

Not applicable

Re: Marketo Integration SFDC Owner

Thank you Josh,

That helps give us a place to start. I think what we're most concerned about is that we have changed nothing on our end, in both Marketo and SFDC and this only started appearing a month ago. So we want to know why it's happening and what triggered it. Marketo has already checked the lead logs and there is nothing in there that has updated or changed the lead owner to Marketo Integration.

But thanks for your help, if you have any other ideas, I'd love to know more about it.

Level 10

Re: Marketo Integration SFDC Owner

Hi Grace,

Give a look to the lead assignment rules in SFDC (setup-> customize-> lead -> lead assignment rules). They might be the cause. They apply only to new leads, so check if this owner is being set when the lead is created in SFDC or updated later.

One of the first thing we do when we setup Marketo in an SFDC environment is to make sure that lead owner and contact owner are "historized" in Salesforce. This helps a lot debugging this kind of issues.