LinkedIn updates not pulling images from landing page

univtechInst_Ma
Level 1

Re: LinkedIn updates not pulling images from landing page

Naor,

LinkedIn is very finicky when pulling meta data from the page. If you want to be sure it's pulling the right image you have to add an img src tag in the head section.

Go to Edit Page Meta Tags>Custom HEAD HTML section on the landing page and add an img src tag and alt tag if you want users to have a choice of images.

Example:

<head>
<img src="http://go.kokopop.com/rs/mktodemo17/images/bucketList.png" alt="http://go.kokopop.com/rs/mktodemo17/images/bucketList2.png">
</head>
Anonymous
Not applicable

Re: LinkedIn updates not pulling images from landing page

Tried that ,same result 
Anonymous
Not applicable

Re: LinkedIn updates not pulling images from landing page

Also that last suggestion just places an image in the header of the page.....
Anonymous
Not applicable

Re: LinkedIn updates not pulling images from landing page

Any other suggestions here, guys?
Anonymous
Not applicable

Re: LinkedIn updates not pulling images from landing page

I'm looking at this marketo lp by example: http://www.marketo.com/definitive-guides/engaging-email-marketing

W
hen put into linkedin, it pulls only ONE single image, even though the page has several. I copied the meta tag from this page and put it on mine, hoping the image would be available, but it does not work.

Something is seriously wrong with my landing pages? 
Anonymous
Not applicable

Re: LinkedIn updates not pulling images from landing page

I'm having the same issue. Marketo -- any news about how to fix this????
Anonymous
Not applicable

Re: LinkedIn updates not pulling images from landing page

FINALLY got the answer to this. Thanks to Ian Young at marketo support. Put the following in your landing page in the custom head area

<meta property="og:image" content="http://www.marketo.com/_assets/uploads/what-is.PNG?20130620133033"/>
<meta property="og:image:width" content="200" />
<meta property="og:image:height" content="200" /></head>

Adjust according to your actual image. This worked for me.
Venus_Wills
Level 3

Re: LinkedIn updates not pulling images from landing page

Thank you for sharing! I've had the same issue with LinkedIn.
Anonymous
Not applicable

Re: LinkedIn updates not pulling images from landing page

I've been having this same issue when I try to share our Marketo landing pages on LinkedIn - no image shows up even though there are a couple on the page. I tried the solution that you got from Marketo but no image is showing up. Did you have to do anything else to make it work other than pasting that code in the custom head section? Is there a time delay? 

Really wish there was an easy way to solve this - seems like a big problem to me since we all know images increase clicks on social!
Anonymous
Not applicable

Re: LinkedIn updates not pulling images from landing page

Gina - If you have already pasted your landing page's URL into linkedin, there is something odd with LinkedIn that will prevent it from "re-loading" the landing page once you've made your corrections using the code above. If that's the case, just change the URL on the marketo side of things and then try it again. I am not sure why LinkedIn acts up in that way. The above code DOES work as I've used it on all landing pages moving forward. 

Not sure that my explanation is as clear as it could be. What I mean is that once you paste a landing page url into linkedin to share, Linkedin does some sort of indexing of that page. If you did not have the above code on that page at the time you pasted it into linkedin, it will never re-index the page even if you make the changes. You can try closing your browser, clearing your cache etc. but it still won't find the images. So you must change the landing page's URL once you have added the code and then try it again in LinkedIn.