Leads Not Syncing with MS Dynamics During Workspace Upload

Darshil_Shah1
Level 10 - Community Advisor + Adobe Champion

Re: Leads Not Syncing with MS Dynamics During Workspace Upload

Sure, @michellechopin!

Darshil_Shah1
Level 10 - Community Advisor + Adobe Champion

Re: Leads Not Syncing with MS Dynamics During Workspace Upload

I do have a feeling that campaign sync being disabled is what is causing the source campaign data not getting to Dynamics from Marketo and AFAIK, source campaign data is a part of the campaign sync and without it being enabled it would not be able to get over to Dynamics from Marketo. ๐Ÿ™‚ 

Let us know what you find.

michellechopin
Level 6

Re: Leads Not Syncing with MS Dynamics During Workspace Upload

Hey @Darshil_Shah1,

 

We've turned on that campaign sync now and I'm running some test leads into Dynamics to see if that solves the issue (currently running into leads prevented from syncing because there are duplicates in Dynamics - that's a whole other project ๐Ÿ˜‹).

 

Once I've managed to get some leads to sync, I'll post an update either way!

 

Appreciate all your help troubleshooting this ๐Ÿ˜€

Michelle

 

 

 

michellechopin
Level 6

Re: Leads Not Syncing with MS Dynamics During Workspace Upload

As promised, keeping thread members updated on this process. The Dynamics Campaign Sync item was turned on but didn't seem to fix what now seems to be a weirdly specific issue.

 

We have two custom fields called Source Campaign and Source Campaign Most Recent, which is where we add the Campaign ID from Dynamics. When leads are either imported with the Source Campaign field, or updated via Marketo Smart Campaign, the two fields are showing the right information within Marketo; however, that data isn't syncing over to Dynamics, even if the lead itself is syncing (all other new data is matching what I see in Marketo, so that's how I know the person sync is happening).

 

This is for leads in the new workspace, so not sure if that has anything to do with it but as I upload new lists into our Default workspace, I'll check whether those leads also fail to get that information in Dynamics. The strangest thing is that this hasn't been an issue to date - I only noticed it with the new workspace/partition uploads but, as you know, there aren't specific settings for those and everything is connected to the same Dynamics instance. 

 

Still super baffling but I'm waiting on a reply from Marketo Support (assuming I've sufficiently baffled them too ๐Ÿ˜‹). Will keep updating as I learn more!

Darshil_Shah1
Level 10 - Community Advisor + Adobe Champion

Re: Leads Not Syncing with MS Dynamics During Workspace Upload

This is little strange, if the MS sync configuration (including field mapping, permissions, etc.) hasnโ€™t changed since the last time it was working (i.e., the source fields were syncing to MS Dynamics from Marketo) it probably needs a look from the Marketo support!

 

Also, you're right about the integration being operating at a instance level OOTB and doesn't filter updates based on the partition a person belongs to by default.