Issues when inserting social buttons on free-form landing page

Dan_Stevens_
Level 10 - Champion Alumni

Issues when inserting social buttons on free-form landing page

Before I open a support case, I thought I'd check to see if others are experiencing the issues we're facing when adding social buttons to a free-form LP.  This is done by dragging the "social button" icon from the LP elements on the right; and then selecting "Like/Recommend Button" from the button type drop-down:

pastedImage_0.png

When clicking the gear icon to configure the buttons, there are several issues we're experiencing.  For example, the "Layout" option is messed up.  When clicking on it, an "undefined" value appears - with no ability to modify this:

pastedImage_1.png

And when attempting to save our configuration by giving it a name, there's no way to do so (the "Custom" text cannot be replaced/edited.

Also, is there no way to turn off specific social networks - like Google+ - so that only our preferred networks are contained in the toolbar?

Something feels very broke here.

3 REPLIES 3
Jim_Thao7
Level 9

Re: Issues when inserting social buttons on free-form landing page

UI wise, this looks bugged.

Regarding the naming, it works when I clicked "SAVE AS".   I just type in a name and click "SAVE".

Regarding the removal of certain social networks, I don't believe that is a feature.  You can try hiding it w/ CSS, just find the place holder elements.

Dan_Stevens_
Level 10 - Champion Alumni

Re: Issues when inserting social buttons on free-form landing page

I ended up opening a ticket with support.  This issue is even worse for Facebook - where none of the options can be configured - it just says "undefined":

pastedImage_0.png

Robb_Barrett
Level 10

Re: Issues when inserting social buttons on free-form landing page

You may want to rethink turning off Google+ links

3 Ways to Use Google+ to Increase Search Rankings : Social Media Examiner