Field value not showing up in SFDC

Hoi_Nguyen3
Level 2

Field value not showing up in SFDC

Hi Community,

We've noticed two separate instances on two separate fields where there was a value in Marketo but the value did not sync over to SFDC. The weird part is that the rest of the fields on the record syncs over to SFDC just fine.

We ruled out the possibility that the error is an "acceptable value" error because the fields in question are both plain text and the values we have been pushing over is simply "Test".

Any ideas?

Thanks,

Hoi

6 REPLIES 6
Josh_Hill13
Level 10 - Champion Alumni

Re: Field value not showing up in SFDC

is the field properly visible to Marketo User?

Hoi_Nguyen3
Level 2

Re: Field value not showing up in SFDC

Hey Josh,

Yes the field is visible to the Marketo user. Additionally, the Marketo user has Modify All permissions on the Lead, Contact, Opp, and Account objects.

Hoi

Raghav_Chugh
Level 1

Re: Field value not showing up in SFDC

Try Matching the Cnames Hoi.

Raghav Chugh
Hoi_Nguyen3
Level 2

Re: Field value not showing up in SFDC

Can you elaborate, RC? I'm not entirely sure I see how CNAMEs work into the equation.

Thanks!
Hoi

Veronica_Holme4
Level 10 - Champion Alumni

Re: Field value not showing up in SFDC

Hoi - OK, in this order this is what I would normally check to find this particular culprit:

In Salesforce:

1. Somebody has already mentioned permissions - Modify All is a good start, but that won't override a Field Level Security block. Check the field itself is writeable by the Marketo Sync User. If you can update one field but not another on the same record this is usually the issue.

2. What you've mentioned is something else I'd normally check, that the value you are writing is something that the SFDC field can accept. In this case you're right, a text field should be fine. Picklists are usually the main problem in that scenario.

3. Ensure there's nothing on the Salesforce side wiping the value as soon as it is entered. Sometimes you may need to turn on Track Field Changes for the field in question to investigate this.

In Marketo:

1. Check your Marketo notifications and see if there's an error/warning about not being able to sync to that field.

2. Check that you don't have a Block Field Update applied to the field on the Marketo side in Admin > Field Management

3. Trying syncing the same value on a different person record, see what happens. Check the activity logs of the person, look for the Change Data Value activity and check the activity itself to see if there are any warnings or messages.

If all that seems fine, you need to go to Marketo Support:

1. Ask Support to check the sync logs and tell you what Marketo is telling them in the back end about syncing that value at that time. You will need to give them a couple of examples where this has happened on a couple of different person records.

Hoi_Nguyen3
Level 2

Re: Field value not showing up in SFDC

Thanks for laying all of this out, Veronica. It is very helpful for any future field sync errors!