Issue
Person record's Activity Log shows repeat Company Name changes without any Data Value Change being logged.
In this example screenshot, we can see that the person had the Company Name set back to the correct value by the CRM sync, but there is no record of the Company Name being changed in the first place.
This is a article attached image
Environment
- Person records showing the change are all part of the same Account.
- One person on that holding Account fills out a form that updates the field "Company Name" to a value that is different from the Account Name
- CRM sync corrects the Company Name field back to Account Name
Solution
STEPS TO RESOLVE:
1. Find the lead that change the Company Name field on the account with a Smart List filter:
DATA VALUE CHANGED
Attribute: Company Name
New Value: [Company Name from form fill-out]
Previous Value: [Account Name]
This is a article attached image2. Locate the Data Value Change in the Activity Log
3. Check the date and time of the Data Value Change
4. Check that timeframe on other affected records
5. The timeframe of the Data Value Change back to the Account Name will approximately match the timeframe of the logged Data Value Change, showing that the update to the one person was the cause of the update for all others on that account.
Root Cause
Marketo uses Company Name as the identifier for the Account object. If you have multiple people on the account and one of them changes the Company Name via a form fill-out, the Company Name is changed for all other people on that Account. This change happens on the back end, so you will not see it until the CRM changes it back to the correct value in the next sync cycle.