Summary
Mismatch between "Added to [custom object]" and "Has [custom object]" filters for a SFDC Custom object
Issue
You build a Smart List for "Added to [custom object]" for your SFDC Custom object and you notice the number of records qualifying is lower than expected.
The "Has [custom object]" filter pulls more records, however, and matches what you see in SFDC.
Environment
SFDC/Marketo
Solution
This is expected behavior if you have records that were already associated to the SFDC Custom object before they were pushed to Marketo.
If you have records that were already associated to the SFDC Custom object before they initially synced to Marketo, those records would not have an "Added to [SFDC Custom Object]" activity on their record in Marketo, which means they would not qualify for the "Was added to [SFDC Custom Object] Smart List filter"
In this scenario, it is recommended to use the "Has [SFDC Custom Object]" filter to get the accurate numbers, as this should include all Marketo records that are associated to the Custom Object, even if they were added to it prior to being synced and created in Marketo.
Root Cause
Records already being associated to the SFDC Custom object before they were initially synced to Marketo.