Interesting Moments not displaying in Dynamics

Issue

Interesting moments not appearing for a user in Dynamics. The interesting moments section on a Contact displays: “No Interesting Moments for [Contact Name]”

Solution

  • Checked that the user is a contact record synced with a Marketo record that has interesting moments
  • Created a new record with interesting moments and synced to Dynamics, but the user still cannot see the interesting moments
  • Sync is validated 
  • No errors found for example records
  • MSI Sync status is ‘Configured’ in [Admin > Sales Insight]
  • Checked on a system admin users access and were able to see the interesting moments for the example records
  • Found that the Marketo Sales Insight security role was not assigned to the affected user, but after assigning the role, clearing browser cookies and cache, logging out and logging back in, the Interesting Moments for the example records was still not appearing
  • Perform the following update:
Go to > Settings > In Marketo API configuration > Form Editor > API secret Key > Details tab > Edit > Disable the field level security

Root Cause

Marketo Sales Insight role was not assigned to the user and Marketo API Configuration had field-level security enabled

Environment

  • Microsoft Dynamics CRM
  • Marketo Sales Insight
  • Interesting Moments

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