Summary
Your global form validation rule is setup/active in Admin, and the rule is enabled on the form, but the rule isn't working.
Issue
Your global form validation rule is setup/active in Admin, and the rule is enabled on the form, but the rule isn't working (emails that should be blocked can still submit)
Environment
Admin
Solution
Check the rule in Admin > Global Form Validation Rules and confirm that there is no '@' prepended to the email domains.
The domains should look like the below:
'gmail.com, outlook.com, acme.org...'
Instead of:
'@gmail.com, @outlook.com, @acme.org..."
Root Cause
'@' referenced in the domain name within the validation rule.