marketo fails to "recognize" custom unsubscribe footer in an email template

Highlighted

marketo fails to "recognize" custom unsubscribe footer in an email template

We are currently launching an automated email campaign that will grab the content of our latest blog post, pack it into an email and send to those who have subscribed to receive such updates.

The major part on email content is inserted to the custom token {{my.Email content}} inserted into our regular email template, but we’ve came across a strange issue – marketo doesn’t seem to recognize the custom unsubscribe footer that we have and enforces the default unsubscribe link at the bottom of an email.

This is very strange, bc the standard {system.unsubscribeLink}} has never yet failed me

Is there some problem in an html that I’ve overlooked?

I’m attaching the original html as well as how an email looks in the mailbox in hopes that someone takes a looks at and might have any idea as to why this is happening.

Will be grateful for any tips

pastedImage_0.png

6 REPLIES 6
Highlighted

Re: marketo fails to "recognize" custom unsubscribe footer in an email template

Hi Vlada,

Sorry I do not have time to dig into your HTML code.

Could you just please paste here the small part of it that contains the link to the unsub page ?

-Greg

Highlighted

Re: marketo fails to "recognize" custom unsubscribe footer in an email template

                <p style="font-family: Arial, Helvetica, sans-serif; font-weight: normal; font-size: 12px; line-height: 16px; margin: 0 0 0 0;">You received this email because you are subscribed to IntelliJ IDEA blog updates.</p>

                <p style="font-family: Arial, Helvetica, sans-serif; font-weight: normal; font-size: 12px; line-height: 16px; margin: 8px 0 0 0;">Adjust your <a href="http://info.jetbrains.com/user-mailing-preferences.html?leadId={{lead.ID}}">mail preferences</a> or <a href="{{system.unsubscribeLink}}">unsubscribe</a> from all communications with JetBrains.</p>

Thank you very much, Greg!

Highlighted

Re: marketo fails to "recognize" custom unsubscribe footer in an email template

Hi gain Vlada,

This seems correct.

If you are using the {{system.unsubscribeLink}} token in all you email templates, it's recommended to deactivate the default one in the admin -> email. set it as is:

pastedImage_1.png

-Greg

Highlighted
Level 10 - Champion Alumni

Re: marketo fails to "recognize" custom unsubscribe footer in an email template

Greg, I believe that's only if you are NOT using the original system unsub page and code. If you use {{system.unsubscribeLink}} Marketo will recognize it and not put in the default.

I wonder if this is caused by using the My Token to drop in the entire footer and then Marketo doesn't fully see the system token at email generation.

Vlada, why do you want to keep using the system link if you have a custom page?

Highlighted

Re: marketo fails to "recognize" custom unsubscribe footer in an email template

Hi Josh and Vlada,

I had not got the fact that the token was in a token (read too fast )

This is the cause: Tokens in tokens are not resolved.

-Greg

Highlighted

Re: marketo fails to "recognize" custom unsubscribe footer in an email template

that's not seems to be the case.

i have both {{my.Email content}} and {{system.unsubscribeLink}} in the template, {{system.unsubscribeLink}} is not inside {{my.Email content}} (if i understood you correctly)