Vidyard Video Disappears on MKTO Landing Page

Highlighted
Level 3

Vidyard Video Disappears on MKTO Landing Page

I'm having an issue where a Vidyard video is disappearing from one of our MKTO landing pages in version of IE above 8. Our target customers mainly use IE, and asking them to view the video in a different browser isn't the ideal experience. My IT team said it may have to do with flash/the browser, and not our firewall. Vidyard can't find a reason why it isn't working. Any thoughts from the community?

VY.blank.jpg

7 REPLIES 7
Highlighted
Marketo Employee

Re: Vidyard Video Disappears on MKTO Landing Page

It looks like there's a javascript error in the vidyard code when rendering in IE8.  You'll need to reach out to them.

Highlighted
Level 10 - Community Moderator

Re: Vidyard Video Disappears on MKTO Landing Page

Chris, it works fine in IE 9 for me.  IE 8 doesn't support HTML5 <VIDEO>, so unless Vidyard falls back to the now-dreaded Flash or another plug-in, the logic will be different there, and may not be fully tested or even supported.  Like Kenny said, you should ask them what they actually support and then report a bug if applicable.

Highlighted
Level 3

Re: Vidyard Video Disappears on MKTO Landing Page

Vidyard found a bug and plans on rolling out an update next week. Hopefully, this will resolve the issue. I appreciate both Kenny and Sanford's responses and will keep you posted on the results of next week's update.

Vidyard told me in a previous conversation that they support even the older IE versions, I believe back to 7 or 8.

Highlighted
Level 10 - Community Moderator

Re: Vidyard Video Disappears on MKTO Landing Page

Good to know.  I think anyone using IE 8 will be okay with Flash anyway. It would be a strange combo of priorities to use IE 8 as your primary browser but turn off Flash!

Highlighted

Re: Vidyard Video Disappears on MKTO Landing Page

Also see this:

Re: Embed YouTube Video - Full Screen

"allowfullscreen" attribute works, but will not be functional in the previewer.

Highlighted
Level 3

Re: Vidyard Video Disappears on MKTO Landing Page

It was actually a bug in Vidyard that they had to resolve. They pushed out the update last week and everything has been working fine since. Thanks everyone for your input!

Highlighted
Marketo Employee

Re: Vidyard Video Disappears on MKTO Landing Page

Glad to see this got resolved.