Marketo - SFDC Sync issue

Highlighted
Anonymous
Not applicable

Marketo - SFDC Sync issue

Hi guys,

Here's the deal: whenever a lead that already exists in SFDC changes their information in Marketo (i.e. a lead changes her name from Jane Smith to Jane Jones) it's not updating in SFDC. Given that it's supposed to be a bidirectional sync, whenever a lead updates information in Marketo it should be syncing to SFDC... but it's not.

Why this is especially weird:

  • New leads sync perfectly (i.e. if Jane Jones becomes a new lead, not just a new version of an old lead)
  • Our marketo user is a system admin in SFDC with standard settings and has full access to change lead names (can change them manually within SFDC without trouble)
  • We have uninstalled any managed packages in SFDC that might possibly interfere with lead sync (no dedupe rules, nothing installed anymore at all)
  • Have contacted SFDC support numerous times, they have no idea why this is happening and have asked me to contact Marketo support
  • Have had a ticket with Marketo support for a while with no answers of any kind coming back from them (which leads me to believe they also don't really know what's up)

Any ideas??

Thanks,

Andrew

11 REPLIES 11
Highlighted
Anonymous
Not applicable

Re: Marketo - SFDC Sync issue

Did you try to manually change name of a lead in Marketo. And 'manually' trigger (right click on the lead) sync with SFDC?

What do you see in the 'activity log' of that lead w.r.t. SFDC ?

Any error in the notifications?

Rajesh

Highlighted
Level 10 - Champion Alumni

Re: Marketo - SFDC Sync issue

Sounds like your user profile isn't quite right, even if it is an Admin.


Are you sure those fields aren't blocked somehow on either end?

Highlighted
Anonymous
Not applicable

Re: Marketo - SFDC Sync issue

What are your organization wide sharing settings? If it's set to private you may need to create a rule for the Marketo Sync user to access Leads/Contacts/Accounts they don't own.

Re: Marketo - SFDC Sync issue

Hi Andrew,

Look at the activity log of the leads that show the problem, focus on the SFDC sync activities and see what is the error code. Various possibilities here, including some details on the hints already provided above:

  1. Check that you do not have a Validation rules in SFDC that prevent the record to be updated
  2. Make sure the user is a true Admin (std profile), in which case the sharing rule have no importance
  3. If not (the profile is a custom one), then make sure it has the right to modify all leads, modify all contacts, view all accounts, and also that, for each objects it can edit all fields. In this case, make sure it has access to all records through the sharing settings
  4. Check that there is not a filter enabled on your sync that prevents certain records to sync

-Greg

Highlighted
Anonymous
Not applicable

Re: Marketo - SFDC Sync issue

ok, got this error: So then I went into SFDC to check the fields, and it turns out we had one called

_updateSObjectsById failed for 1 Lead record(s) - INVALID_FIELD: No such column 'mkto_si__Last_Interesting_Moment_Date__c' on entity 'Lead'. If you are attempting to use a custom field, be sure to append the '__c' after the custom field name. Please reference your WSDL or the describe call for the appropriate names.

'mkto_si_Last_Interesting_Moment_Date_c__c', so I deleted the extra '_c' and got this:

_retrieveSObjects failed for type 'Lead' - INVALID_FIELD: MasterRecordId, Mike_Old_Leads__c, mkto_si_Last_Interesting_Moment_Date_c__c ^ ERROR at Row:1:Column:945 No such column 'mkto_si_Last_Interesting_Moment_Date_c__c' on entity 'Lead'. If you are attempting to use a custom field, be sure to append the '__c' after the custom field name. Please reference your WSDL or the describe call for the appropriate names.

Now, I've never had any trouble with Mike_Old_Leads_c before, or MasterRecordId. Any idea what's going on here?

Thanks,

Andrew

Highlighted

Re: Marketo - SFDC Sync issue

Hi Andrew,

You should really not play with these fields, they arepart or Marketo Sales Insight packages.

I recommend that you deinstall MSI and reinstall it properly. It will be faster than trying to correct all this.

-Greg

Highlighted
Anonymous
Not applicable

Re: Marketo - SFDC Sync issue

quick instructions on where to find MSI to uninstall? Don't see it under our managed packages in SFDC.

Also, do you have a link to reinstall it?

Sorry I'm so helpless!

Andrew

Highlighted
Anonymous
Not applicable

Re: Marketo - SFDC Sync issue

(it looks like we might not have installed MSI at all)

Highlighted

Re: Marketo - SFDC Sync issue

Hi Andrew,

I would bet MSI has been installed in the past, and then removed... Do not worry about the "Mike Old Leads" one, the error is not on it.

Link to install MSI: Install Marketo Sales Insight Package in Salesforce AppExchange - Marketo Docs - Product Docs

I would also review the rights of the Marketo user. Either it has the "system administrator" profile (non custom) or you need to make sure all fields are made visible to it in each key object.

-Greg