SOLVED

Issues submitting embedded Marketo forms on website

Go to solution
Jenn_Rogers_Kel
Level 1

Issues submitting embedded Marketo forms on website

We are currently experiencing intermittent issues with submitting embedded Marketo forms on our website. When submitting the form we get an error that says Submission failed, please try again later. Below are the three pages experiencing the issue. 

Screen Shot 2020-06-25 at 4.04.09 PM.png

We have an open ticket with support but wanted to see if anyone here has experienced the same issue? 

Thank you!

Jenn Rogers
1 ACCEPTED SOLUTION

Accepted Solutions
SanfordWhiteman
Level 10 - Community Moderator

Re: Issues submitting embedded Marketo forms on website

It's because you're trying to load forms from 2 different aliases for the same server. This causes a race condition and the error you've observed.  All forms need to load from your LP domain www2.constructionline.co.uk — don't use your *.marketo.com domain.

 

2021-02-05 13_48_13-https___constructionline.wordpress.magpiex.co.uk_bolt-on_ - Waterfox (Private Br.png

 

View solution in original post

9 REPLIES 9
SanfordWhiteman
Level 10 - Community Moderator

Re: Issues submitting embedded Marketo forms on website

You need to turn off all the GTM tags you have that affect forms in order to test this with a clean slate. I doubt it has to do with the vanilla forms embed — but you need to have a vanilla form to compare.

Hoi_Nguyen3
Level 2

Re: Issues submitting embedded Marketo forms on website

We are experiencing the same issue. I'm unclear if Sanford's response was a solution or just commentary about how to test/reproduce the error. 

 

Can you confirm if you've found a solution for this?

 

Thanks,

Hoi

Hoi_Nguyen3
Level 2

Re: Issues submitting embedded Marketo forms on website

Here is the link with the embedded form on our site: https://www.greenhouse.io/open-sponsorship-interest.

 

We are getting the same error as Jenn. We submitted using Chrome version 86 and Safari 14, and got errors both times.

SanfordWhiteman
Level 10 - Community Moderator

Re: Issues submitting embedded Marketo forms on website

Need a page where you can reproduce the failure given certain input criteria.

 

And make sure you have turned off every custom form behavior (you have at least 4, from different vendors) when testing.

Caleb_Kelly
Level 1

Re: Issues submitting embedded Marketo forms on website

Any updates on this? We are experiencing a similar issue.

 

Form appears to work on IE, but throws "Submission failed, please try again later" error when using Chrome.

SanfordWhiteman
Level 10 - Community Moderator

Re: Issues submitting embedded Marketo forms on website

Need a link to your page to see what's wrong with your setup.
maddie_jtf
Level 1

Re: Issues submitting embedded Marketo forms on website

Hi Stanford, we're having the same issue with 2 forms, although clearing the cache will sometimes let you submit the form once. Developers said they stripped everything to do with GTM on the forms and we're a bit stumped as to why they're not working. They've been cloned from forms that work. If you could have a look and let me know what else we could try, I'd appreciate it.

 

1. https://constructionline.wordpress.magpiex.co.uk/bolt-on/

2. https://www.constructionline.co.uk/events/issues-tab-webinar-feedback/ 

 

Thank you,

Maddie

SanfordWhiteman
Level 10 - Community Moderator

Re: Issues submitting embedded Marketo forms on website

It's because you're trying to load forms from 2 different aliases for the same server. This causes a race condition and the error you've observed.  All forms need to load from your LP domain www2.constructionline.co.uk — don't use your *.marketo.com domain.

 

2021-02-05 13_48_13-https___constructionline.wordpress.magpiex.co.uk_bolt-on_ - Waterfox (Private Br.png

 

View solution in original post

maddie_jtf
Level 1

Re: Issues submitting embedded Marketo forms on website

Amazing, thank you!