Webhook URL Error Code 404: URL not found

Not applicable

Webhook URL Error Code 404: URL not found

Hi all,

We are getting this URL error code, after having installed a successful webhook - we are now seeing issue with it and getting this same error code over and over again -- is anyone else having this problem? If so, how are you solving for it?


Level 10 - Community Moderator

Re: Webhook URL Error Code 404: URL not found

The problem is that loopback connections to localhost/.../save are not really, truly supported -- in the sense that Marketo doesn't retest this functionality as instances get migrated/upgraded. If you search the Community, you'll see that over the years users have reported that their instance worked, then stopped working, while for other users it continues to work or never worked at all. It's frustrating.

You may find that the problem is that SSL is required, so try https://localhost (although this won't work unless SSL cert validity is being ignored).

In general, I would recommend not using the localhost address for this but setting up an API gateway (you can use Amazon CloudFront) to do an implicit loopback to your instance /save. That is, set up a hostname like marketo-endpoint.example.com and have it go to CF and then back to Marketo. This will always work.