Problems appending new values

david-zweben
Level 1

Problems appending new values

Hello,

 

I'm trying to set up a Smart Program that logs a change history of one of our fields into a text area field. The program is set up like this:

 

Smart List: Trigger when "Person Status" data value changes

Flow: Change data value "Person Status History" to

{{lead.Person Status History}}{{my.linebreak}}{{system.dateTime}} - {{lead.Lead Status}}

 

This is intended to append a new line that looks like this:

03/04/2022 8:45 AM - New Lead Status Here

 

Appending a value works as expected, the only problem is that the value that gets appended is the previous value, not the new one.

 

How can I set up this type of logging functionality and be sure to capture the just updated value of a field, rather than its old value? I'm pretty sure this is an issue with things happening asynchronously, but I don't know how to prevent it.

 

Thanks!

3 REPLIES 3
Darshil_Shah1
Level 10 - Community Advisor

Re: Problems appending new values

I've never faced this kind of issue even in pretty loaded/slow instance with the stale value getting appended to the field - since the campaign itself triggers when the data value change happens on the person's field in the lead database, and Marketo's flow step is gonna reference the same person field data from the lead database! Do you have any additional triggers that might be triggering off this campaign?

Best,
Darshil
david-zweben
Level 1

Re: Problems appending new values

Hi Darshil,

 

No, the configuration I described above is 100% of that Smart Campaign's configuration.

Darshil_Shah1
Level 10 - Community Advisor

Re: Problems appending new values

Thanks for confirming, @david-zweben ! Can you please share the snapshot of the person’s activity log where you see the stale data getting appended by the campaign flow step after the value on Person Status field has updated (which actually triggered off the update campaign)?

Best,
Darshil