Marketo not pushing information to Salesforce

SaraRoulston
Level 2

Marketo not pushing information to Salesforce

Hi there, I have been working on a landing page and form to submit potential leads to Salesforce. When everything is approved and I try to submit a test lead via the form on the landing page it only gets created in Marketo but not Salesforce. I have already checked if Marketo is syncing to Salesforce and it is. I have tried using a cloned form with changes to fit the criteria needed and creating a new form (similar criteria) and both only show in Marketo and not Salesforce. I did use the form I originally cloned to see if that worked and it did, however, the criteria is obviously not what need for this project. 

 

Please let me know what criteria or pictures I can provide to give you guys a better idea. I'm new to Marketo so any suggestions and help would be greatly appreciated, thanks! Attached are two screenshots, the first is the cloned version and the other is a brand new form. I did receive different options for drop down on the LSD & How did they reach us? so I used what best fit. The criteria the leads would be filling out is basic information; name, email, phone, etc.

Form 3.PNG

Form 2.PNG

4 REPLIES 4
Tyron_Pretorius
Level 8

Re: Marketo not pushing information to Salesforce

There are two things you can try:

i) Wait for 5 Selection_102.pngminutes to see if the lead then syncs to Salesforce. Marketo and Salesforce sync every 5 minutes on their own to transfer lead info.

ii) If i) does not work then use the "Sync Person to Salesforce" flow action in a smart campaign or find the person in a list view and do the same.

 

If the lead still does not sync after ii) then screenshot the error returned from the activity log here for further debugging

Tyron Pretorius
SaraRoulston
Level 2

Re: Marketo not pushing information to Salesforce

Thanks @Tyron_Pretorius, I'll give this a try!

 

 

SaraRoulston
Level 2

Re: Marketo not pushing information to Salesforce

@Tyron_Pretorius  so the lead did not automatically sync and I tried the steps you provided and was able to sync the lead to Salesforce myself. With the reach of this campaign my hope is that I would not have to individually sync every lead coming in. Is there an issue with the form in which it is not allowing these leads to sync from Marketo to Salesforce? Any insight you have would be great, thanks for your help!

 

Tyron_Pretorius
Level 8

Re: Marketo not pushing information to Salesforce

Sara do you have a custom sync filter enabled? Take a look at the article below

 

https://nation.marketo.com/t5/Knowledgebase/Restricting-Leads-from-Syncing-to-SFDC-With-Sync-Filters...

 

In our instance we have a smart campaign that sets our custom sync filter field value to true for any new lead created so that they will sync to Salesforce and vice versa.

 

If you are not setting this for newly created leads this could be why they are not syncing naturally every 5 mins

Tyron Pretorius