SOLVED

Filters in segments (web personalization)

Go to solution
lextraza
Level 2

Filters in segments (web personalization)

Why filter from database "marketing opt in" = yes doen't work? We created a lead with opt-in = yes, but the content is not shown to him. 

lextraza_0-1652091824020.png

 

1 ACCEPTED SOLUTION

Accepted Solutions
Darshil_Shah1
Level 10 - Community Advisor

Re: Filters in segments (web personalization)

You would need to use this segment to show the dynamic content to the people based on their segment membership, there are majorly couple of ways to do that:

 

1. Use this segment in a web-campaign

2. Use the RTP JS methods to get the segment data of a visitor, and personalize the content on the web-page using custom JS

 

Also, segment associations aren't very fast, and it may take few minutes for Marketo to associate a person to the segment upon qualification, hence you may not see the dynamic data configured for a segment immediately after updating the field-data on the person record (i.e., Marketing Opt In = yes).

 

Best,
Darshil

View solution in original post

5 REPLIES 5
Darshil_Shah1
Level 10 - Community Advisor

Re: Filters in segments (web personalization)

You would need to use this segment to show the dynamic content to the people based on their segment membership, there are majorly couple of ways to do that:

 

1. Use this segment in a web-campaign

2. Use the RTP JS methods to get the segment data of a visitor, and personalize the content on the web-page using custom JS

 

Also, segment associations aren't very fast, and it may take few minutes for Marketo to associate a person to the segment upon qualification, hence you may not see the dynamic data configured for a segment immediately after updating the field-data on the person record (i.e., Marketing Opt In = yes).

 

Best,
Darshil
lextraza27
Level 1

Re: Filters in segments (web personalization)

We used this segment in Web campaign and do some tests with leads with opt in=yes. However, the content, that should be shown to those leads - is not shown. And we are wondering why does not it work

Darshil_Shah1
Level 10 - Community Advisor

Re: Filters in segments (web personalization)

Ah okay, thank you for sharing that! Can you try troubleshooting by checking following items?

 

  • Ensure the RTP JS is placed on the target webpage (if you have more than one domains added to your webpages, you need to ensure that correct domain’s RTP JS is added on the webpage).
  • Ensure that the correct target domain is set on the segment and campaign.
  • In the segment page, do you see count for known people matches? If your segments doesn’t show any matches, campaign won’t be called to action.
  • Do you see any JS errors on the browser’s F12 console?
  • Verify the correct zone id is set in the campaign in case you’re setting up an in-zone campaign.


There are some more troubleshooting steps here including the key/most probable cause I listed above that you may refer if all the above seem to check-out correctly.

Best,
Darshil
lextraza27
Level 1

Re: Filters in segments (web personalization)

Thanks for your answer. We will definetly try that. Moreover, we tried to use filters like "browser = not Google chrome" and that worked right. But when using "status = Anonymous (or Known)",  "Opt In = yes" or static lists - campaign doesn't work for those leads and as the result, they do not see content.

Darshil_Shah1
Level 10 - Community Advisor

Re: Filters in segments (web personalization)

This clearly indicates that the known visitors are are not being associated correctly to the segment that you've created and if the segment configuration is correct and if you still see this issue persistently, I would recommend you to request Marketo support to look in to it. I've witnessed cases where-in the segment association took few hours post the actual data data update in the db.

 

Best,
Darshil