Re: Execute campaign flow step issues?

Level 5

Execute campaign flow step issues?



I haven't had a lot of time yet to thoroughly explore the issue, but I could swear I have had issues with the new "execute campaign" flow step. 

I am under the impression that a campaign I was working on worked well once, then after deleting my test lead, stopped working. Specifically I noticed that the campaign was called, but the parent campaign did not seem to continue executing, as if the executable campaign never came back to the parent campaign with a result. 

Another issue I have had is that I could not delete this parent campaign. I tried some days later and I was able to. 


Has anyone experienced any or similar issues?

Before I start refactoring and using this flow step extensively, I would like to be sure there are no major issues with it. 



Level 8 - Champion

Re: Execute campaign flow step issues?

Hi Victor, do you see anything on the executed campaign results tab? Do you have any smart list rules on the executed campaign? If there is an issue with the smart list (e.g. invalid criteria or logic) it will fail.

Someone mentioned having trouble deleting the campaigns, but that may be more related to the app/navigation cache (which Marketo support can clear).

Level 5

Re: Execute campaign flow step issues?

Hi Beth, 


Thanks for your help. 

That particular incident turned out to be our own fault. 

We had an archived triggered campaign we weren't aware of messing with our process and it made the executable campaign look like the problem. 

I have not used them since so I can't really say much for now 🙂 


I have noticed that they don't run if there are errors and one very cool feature of them is that the activity log will explicitly say if someone qualified or not when it tried to execute, makes troubleshooting easier. 

Request campaign is not explicit, so there could be other things going on that explain why something didn't happen.