Re: Custom email template is not displaying correctly in web browser

Nihal
Level 1

Custom email template is not displaying correctly in web browser

I have created an email template while in preview email template looks perfectly fine, but while I am sending sample email it doesn't appear correctly all the images, format and sections are miss aligned. Sections have changed their places.

Please help me with what possibly went wrong!! 

3 REPLIES 3
Vinay_Kumar
Level 8 - Community Advisor

Re: Custom email template is not displaying correctly in web browser

There can be issue with table structure, tags or image code, however it is tough to share the exact issue without analyzing the code. 

Jo_Pitts1
Level 10 - Community Advisor

Re: Custom email template is not displaying correctly in web browser

@Nihal ,

can you provide the code, and some screenshots of the issues you're having.

 

Dave_Roberts
Level 10

Re: Custom email template is not displaying correctly in web browser

One of the reasons you may be seeing a difference here is that in the preview mode, you're using the browser to render the code and in general browsers are more capable of supporting different HTML and CSS than an Email Service Provider (inbox). Once you send the code to an inbox, you're relying on Outlook or Gmail (or whatever) to render that code and each inbox has it's own rules and preferences that are generally archaic compared to a modern browser.

 

There's a really handy website that'll help you figure out what you can and cannot use in email that might be of help to you here:
https://www.caniemail.com/

 

If you're able to post the code and more specific information about the errors you're seeing here that would help the folks in the community look into this one.