SOLVED

Clicks Link on Web Page Trigger Not Firing

Go to solution
ReneeMcDonald1
Level 2

Clicks Link on Web Page Trigger Not Firing

Hi all - I'm trying to set up a triggered campaign that will fire when leads engage with a piece of ungated content but am getting stuck on the trigger. I came across Sandford's solution here but the team ultimately wants to use a WP page with a "download" button that redirects to the asset, rather than running the suggested script on a blank LP. 

 

The asset is a MKTO hosted PDF that is being sent to our database via email. The idea is the click the email link, then click download on the LP and get redirected to the asset. I'm using the Clicks Link on Web Page trigger but it's not firing. Wondering if I set it up wrong? Also, why the referrer is coming through as www.procurify.com/ rather than www.procurify.com/bg2023/ on the activity details?

 

Here are screenshots:

activity details:

Screenshot 2023-06-28 at 6.46.01 PM.png

 

Activity log:

 

Screenshot 2023-06-28 at 6.31.26 PM.png

 

smart campaign: Link Name >  starts with > launch.procurify.com/rs/966-LWV-199/images/2023_Buyers_Guide_v1.00%251.pdf?

Screenshot 2023-06-28 at 5.56.10 PM.png

 

 

 Appreciate any insights!

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Darshil_Shah1
Level 10 - Community Advisor

Re: Clicks Link on Web Page Trigger Not Firing

In your activity log, you have the link name set to "launch.procurify.com/rs/966-LWV-199/images/2023_Buyers_Guide_v1.00%1.pdf" whereas in your trigger you have it set to "launch.procurify.com/rs/966-LWV-199/images/2023_Buyers_Guide_v1.00%251.pdf?". I bet your trigger isn't firing because of this difference.

 

Additionally, w.r.t. to your referrer question: The Referrer header can contain an origin, path, and query string, and may not contain URL fragments (i.e. #section). The request's referrer policy defines the data that can be included in the Referer header. Chrome’s current default since July 2020 is strict-origin-when-cross-origin. This means unless the source site is specifically configured to reveal more of its own visitor data, and the sites are on different origins (crucial note: https://www.example.com and https://pages.example.com do not have the same origin!) the target site will only see the Referrer “https://www.example.com”. I think that explains why you're seeing just the URL "http://www.procurify.com/" as the referrer URL instead of the complete URL "http://www.procurify.com/bg2023/".

 

View solution in original post

3 REPLIES 3
Darshil_Shah1
Level 10 - Community Advisor

Re: Clicks Link on Web Page Trigger Not Firing

In your activity log, you have the link name set to "launch.procurify.com/rs/966-LWV-199/images/2023_Buyers_Guide_v1.00%1.pdf" whereas in your trigger you have it set to "launch.procurify.com/rs/966-LWV-199/images/2023_Buyers_Guide_v1.00%251.pdf?". I bet your trigger isn't firing because of this difference.

 

Additionally, w.r.t. to your referrer question: The Referrer header can contain an origin, path, and query string, and may not contain URL fragments (i.e. #section). The request's referrer policy defines the data that can be included in the Referer header. Chrome’s current default since July 2020 is strict-origin-when-cross-origin. This means unless the source site is specifically configured to reveal more of its own visitor data, and the sites are on different origins (crucial note: https://www.example.com and https://pages.example.com do not have the same origin!) the target site will only see the Referrer “https://www.example.com”. I think that explains why you're seeing just the URL "http://www.procurify.com/" as the referrer URL instead of the complete URL "http://www.procurify.com/bg2023/".

 

ReneeMcDonald1
Level 2

Re: Clicks Link on Web Page Trigger Not Firing

Hi Darshil,

 

Thanks for your response. Sometimes you just can't see the simplest thing after staring at it for so long 😂. It looks like that fix is working! Now I know to use the asset name in the activity log rather than the .pdf URL in design studio.

 

Thanks for the referrer URL explanation as well. I'll use web page as a constraint instead of referrer. Appreciate the guidance! 

Darshil_Shah1
Level 10 - Community Advisor

Re: Clicks Link on Web Page Trigger Not Firing

You're very welcome! It happens to the best of us. Sometimes, we overlook the simplest solutions when we're too focused. I'm glad to hear that the fix is working for you!