SOLVED

Auto Assignement to a account owner doesn't work

Go to solution
Anonymous
Not applicable

Auto Assignement to a account owner doesn't work

Hi everyone,

I am currently trying to improve my assignment according to the filter "Sync to SFDC" in my Smart Campaign's flow, in order to assign a lead or a contact to the right Account owner.

In fact, my goal is that when someone downloads one of our contents and, he or she is one of our Customers, I would like to assign him/her to the right Account owner, plus the programed email won't be sent to the customer as well.

Throughtout the testing phase the process seemed working well.; beforehand I created a fake account with the status "Customer", assigned to one of our Account executive. Then I created a fake contact belonging to the fake account and assigned him to the right Account owner; 

Here are the filters :

pastedImage_4.png

pastedImage_3.png

However, when a new lead (even if he or she is from a customer's company), gets assigned to myself instead of the right account owner, thereby the email is sent to him whereas I don't want.

Does anyone know how to fix it please ?

Thank you

Best

- Etienne

1 ACCEPTED SOLUTION

Accepted Solutions
Grégoire_Miche2
Level 10

Re: Auto Assignement to a account owner doesn't work

Hi Etienne,

In SFDC, Leads have not account, only the contacts have. This means that the account owner on leads will always be empty. and so will the account status. Leads are not attached to accounts like contacts are (even if you have a custom setting in SFDC that links leads to account, this will not be reflected in the "account" fields in Marketo). In you flow, the assignment rules with therefore run, but pay attention, LAR only fire the first time the lead is inserted in SFDC, not when the lead is updated. See

-Greg

View solution in original post

2 REPLIES 2
Grégoire_Miche2
Level 10

Re: Auto Assignement to a account owner doesn't work

Hi Etienne,

In SFDC, Leads have not account, only the contacts have. This means that the account owner on leads will always be empty. and so will the account status. Leads are not attached to accounts like contacts are (even if you have a custom setting in SFDC that links leads to account, this will not be reflected in the "account" fields in Marketo). In you flow, the assignment rules with therefore run, but pay attention, LAR only fire the first time the lead is inserted in SFDC, not when the lead is updated. See

-Greg

View solution in original post

Anonymous
Not applicable

Re: Auto Assignement to a account owner doesn't work

Hi Greg,

It's too bad...Thank you very much for those explications !

By the way I voted for your idea, it might be good if we could have the possibility to choose between the assignement triggered on update or not.

Have a great day

- Etienne