SOLVED

Salesforce sync not working

Go to solution
Mihai_Bejgu
Level 3

Salesforce sync not working

Hi ,

For several days I noticed that Salesforce and Marketo data is not syncronizing anymore.

For example, if I change the Lead Status in Salesforce it will not update the status in Marketo also and vice versa.

If a lead will be created in Salesforce it will not appear in Marketo.

Also when I try to syncronize campaigns from Marketo to salesforce I receive the error from the attached picture.

The weird part is that I don't have any Notifications with any mentions of the sync problems and I don't know how to identify the issues. Did anyone experience this issue before? What should I do to fix it? (or at leas identify the issue)?

Kind regards,

Mihai

1 ACCEPTED SOLUTION

Accepted Solutions
Gerard_Donnell4
Level 10

Re: Salesforce sync not working

Hi Mihai Bejgu​,

Have you went to the Salesforce tab in Admin and checked the last time the sync happened?  See picture below.  I would start there and then would check with the Salesforce admin to see if changes were made on their side around the time of the last sync.

I would also check that the Sync user is still set up correctly.  Maybe someone did a clean up and deleted the profile or changed the settings.  The fact that you are receiving no notification leads me to believe that the connection between the two systems is broken as if they were still connected you would be receiving sync errors from Salesforce, or that is what I would expect to see anyway.

There is a full list of documentation on the sync in the Marketo Docs Step 2 of 3: Create a Salesforce User for Marketo (Enterprise/Unlimited) - Marketo Docs - Product Do...

salesforce-sync.jpg

View solution in original post

3 REPLIES 3
Gerard_Donnell4
Level 10

Re: Salesforce sync not working

Hi Mihai Bejgu​,

Have you went to the Salesforce tab in Admin and checked the last time the sync happened?  See picture below.  I would start there and then would check with the Salesforce admin to see if changes were made on their side around the time of the last sync.

I would also check that the Sync user is still set up correctly.  Maybe someone did a clean up and deleted the profile or changed the settings.  The fact that you are receiving no notification leads me to believe that the connection between the two systems is broken as if they were still connected you would be receiving sync errors from Salesforce, or that is what I would expect to see anyway.

There is a full list of documentation on the sync in the Marketo Docs Step 2 of 3: Create a Salesforce User for Marketo (Enterprise/Unlimited) - Marketo Docs - Product Do...

salesforce-sync.jpg

View solution in original post

Mihai_Bejgu
Level 3

Re: Salesforce sync not working

Thanks Gerard. I managed to isolate the problem with your suggestion.

Kind regards,

Mihai

Gerard_Donnell4
Level 10

Re: Salesforce sync not working

Great! Glad you got it sorted.

Thanks,

Gerard