SOLVED

ICS file working for some but not all emails

Go to solution
Anonymous
Not applicable

ICS file working for some but not all emails

For an upcoming webinar, I created an "Add to Calendar" ics file token. In the description section of the calendar file, I included another token for the Access URL to the webinar. It looks like this:

Access URL: {{member.webinar url:default= }}

My "thanks for registering" email includes the "Add to Calendar" link beautifully, and when you click on it the ICS file is downloaded. When it opens, there is the access URL link, working great. 

My question/problem: I created another email as a reminder of the webinar. I used the exact same Add to Calendar token. The exact same one! When I send myself a live test of this reminder email, I still get a good Add to Calendar link, and the ICS file still downloads correctly, but when you open up the event on the calendar to see the description, it just says, "Access URL:          " with no link at all. Just blank space. 

How is this happening when I'm calling on the exact same token and the exact same ICS file? 

Any help is welcome. I'm stumped!
Tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
JD_Nelson
Level 10 - Community Advisor

Re: ICS file working for some but not all emails

Are you sure you're nesting programs? I don't believe email programs will nest under event programs -- only emails sent with a smart campaign.  If that was the case then the ics file may be in one email program and not the other.  I would recommend putting them all in a folder and then create a mytoken for the ics file in the folder, which will then cascade to your programs under it.  Maybe post a screenshot of the program hierarchy? 

View solution in original post

7 REPLIES 7
JD_Nelson
Level 10 - Community Advisor

Re: ICS file working for some but not all emails

are you using Member.Status to pull the list of people to email to?  Perhaps you're calling just email addresses and there are duplicates and it's pulling a different lead with the same email?  Also the assumption that the email is created within the same Program as your tokens...?
Anonymous
Not applicable

Re: ICS file working for some but not all emails

So far I haven't done anything for my Smart List in terms of where to pull the list of people to email to. I've just set up a Test campaign which says send X email to my email address. 

Yes, both emails (the one where the ICS file is working and the one which isn't) are created under Email Programs, which are both under the Event Program (my webinar). 

Still the strangest thing to me is that the actual token that I place with both emails that says "Add to calendar" is working on both emails. It's just once you download the ICS file, one of the emails always gives me a file with description that includes a link to access the webinar and the same file from the other email always gives me a file with a description that is "Access URL: (blank....)" It doesn't say blank - it just says nothing. 
JD_Nelson
Level 10 - Community Advisor

Re: ICS file working for some but not all emails

Are you sure you're nesting programs? I don't believe email programs will nest under event programs -- only emails sent with a smart campaign.  If that was the case then the ics file may be in one email program and not the other.  I would recommend putting them all in a folder and then create a mytoken for the ics file in the folder, which will then cascade to your programs under it.  Maybe post a screenshot of the program hierarchy? 

View solution in original post

Anonymous
Not applicable

Re: ICS file working for some but not all emails

Hi Nelson,

I organized a webinar using GoToWebinar.

I faced something similar as well. I created the "Add to Calendar" ics file token in the webinar program itself. In the description section of the calendar file, I included another token for the Access URL to the webinar. It looks like this:

Access URL: {{member.webinar url:default= }}

However, when my registrants tried download the ics , they found the link blank. They didnt get the link from me in their add to calendar invite.

Can you pls point me where I could have done the mistake? I am assuming the gotowebinar should ideally send this to me once they register, which it did. But my calendar file token didn't pick the unique url.

Any guidance would be truly appreciated.

JD_Nelson
Level 10 - Community Advisor

Re: ICS file working for some but not all emails

You'll always need to make sure you allow enough time from the time of form submission to get to GTW and back to Marketo before the email is sent. Sometimes 5-10 min for safety.

A second option is to have your default link be the webinar reg default (not best, but sure beats blank!).

Add 5-10 min in there before sending and let me know if it works?

Anonymous
Not applicable

Re: ICS file working for some but not all emails

Hi Nelson,

Will try this and update you shortly. Thanks for your response.

Anonymous
Not applicable

Re: ICS file working for some but not all emails

Oh - you're exactly right! The problem was that I had an email program under my event program so the member.url thing was looking for members in the email program and not finding them. 

I will have to put the mytoken ics file in the folder instead of in the event program so they all can use it correctly. 

Thank you SO much. 

-Allison