SOLVED

Token in MSI email displaying GUID to recipient

Go to solution
Highlighted

Token in MSI email displaying GUID to recipient

I recently created a template for a sales person that had two tokens in the subject line and body. The "lead.first name" token rendered properly, but the other token was for a lookup field in DCRM and even though the test looked normal, the email displayed a GUID for the recipient. This is what the subject line was displayed as: "Jason, re-evaluating the 48696767-d5cd-e011-a1cc-005056a32a27 VoC program?"

Has anyone came across this before? I'm wondering if this is a security setting or something with the corporate server of the recipient. We use other lookup field tokens all the time and have never seen this before. Any insight or personal experience would be appreciated!

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Level 10 - Champion Alumni

Re: Token in MSI email displaying GUID to recipient

Chelsea - yea, the account tokens should work fine.  It's those custom objects that aren't supported.  Here's some related threads (unfortunately, no formal Marketo documentation):

(it's says "working on it now" - but that was back in 2016.  I'm not holding out hope for this one)

Syncing "friendly" custom entity values from MS Dynamics CRM

Dynamics fields showing hashed values in Marketo sync

Related Object fields Coming over as GUID

View solution in original post

3 REPLIES 3
Highlighted
Level 10 - Champion Alumni

Re: Token in MSI email displaying GUID to recipient

Hi Chelsea - I'm actually surprised that the lookup field rendered properly in your tests.  Marketo doesn't support custom lookup fields (like "owned by") - they will always just resolve to the GUID.  Is this a specific/custom object you're working with?

A couple years ago at Summit, Marketo mentioned they would support this for DCRM users - but nothing ever came out of it.

Highlighted

Re: Token in MSI email displaying GUID to recipient

Hi Dan, thanks for your response! We use the account name token {{company.company name}}, which is a lookup field, in our MSI emails and have haven't had problems with that token. This is the first time I've seen the GUID in a response that has come back. This was however the first time I used the {{company.incumbent}} token, which is a custom object. Sounds like the custom object is what isn't supported. Do you know if this is documented anywhere?

But yes, very odd our internal tests showed the correct value when the GUID was being sent out to recipients.

Highlighted
Level 10 - Champion Alumni

Re: Token in MSI email displaying GUID to recipient

Chelsea - yea, the account tokens should work fine.  It's those custom objects that aren't supported.  Here's some related threads (unfortunately, no formal Marketo documentation):

(it's says "working on it now" - but that was back in 2016.  I'm not holding out hope for this one)

Syncing "friendly" custom entity values from MS Dynamics CRM

Dynamics fields showing hashed values in Marketo sync

Related Object fields Coming over as GUID

View solution in original post