Why is my Engagement Score not matching with the Engagement Score in Email Insights?

Issue

When comparing the Engagement Score on the Engagement Dashboard, the scores do not match with the Email Insight Engagement Scores.

Environment

  • Engagement Program
  • Email Insight

Solution

The Engagement Score from the Engagement Dashbaord will hold the most accurate information as this is direct information, rather than for example with RCA/RCE and Email insights where the data source is different.

If you want to see Engagement Score over a period of time more accurately, use the Engagement Stream performance report: Engagement Stream Performance Report | Adobe Marketo

Root Cause

The Engagement Score on the Engagement Dashbaord only calculates the last 3 casest, it is also important to remember that the engagement score only includes emails that were cast more than 72 hours ago. As per this documentation: The Engagement Dashboard | Adobe Marketo

In comparison, the Email Insight Engagement Score is calculated over a period of time that is set by the user but the data can still be mismatching, this is due to the fact that the data source is not the same from the Engagement Dashboard.