2 Replies Latest reply on Feb 25, 2014 8:21 PM by 47388

    Marketo ISSUE MKBW-128

           
                We are facing the problem below. We suspect it is an marketo api issue. 
           
                 
           
                Pls. find blow the result response from a getLead operation.
           
                      
                     <result>
                     <count>1</count>
                     <leadRecordList>
                     <leadRecord>
      <Id>1000483</Id>
                     <Email>tt@tt.com</Email>
      <ForeignSysPersonId xsi:nil = "true"/>
      <ForeignSysType xsi:nil = "true"/>
                     <leadAttributeList>
                     <attribute>
                     <attrName>Company</attrName>
                     <attrType>string</attrType>
                     <attrValue>tt</attrValue>
                     </attribute>
                     <attribute>
                     <attrName>FirstName</attrName>
                     <attrType>string</attrType>
                     <attrValue>tt</attrValue>
                     </attribute>
                     <attribute>
                     <attrName>LastName</attrName>
                     <attrType>string</attrType>
                     <attrValue>tt</attrValue>
                     </attribute>
                     <attribute>
                     <attrName>LeadScore</attrName>
                     <attrType>integer</attrType>
                     <attrValue>2</attrValue>
                     </attribute>
                     <attribute>
                     <attrName>LeadStatus</attrName>
                     <attrType>string</attrType>
                     <attrValue>Open - Not Contacted</attrValue>
                     </attribute>
                     </leadAttributeList>
                     </leadRecord>
                     </leadRecordList>
                     </result>
      This Lead has been sync up with SFDC . 
      0EM50000000RWTX
      0EM50000000RWTc


           The problem is why the ForeignSysPersonId and ForeignSysType is empty.
            
           Could you help us to prove or show us a way to display these two fields with valid value?