4 Replies Latest reply on Sep 16, 2014 2:57 AM by Cheryl Chavez

    Cloning smart campaigns to a different workspace

    Nancy Casler (OG PROD)
      I'm trying to come up with a good way to automate the creation of status (smart) campaigns that we use repeatedly for a variety of programs in our multiple workspaces. These include clicked, opened, bounced, invalid, and unsubscribed. I set up a folder in the default workspace, and within that is a "test program" that contains these 5 smart campaigns that are not hooked up to any emails or programs...they're just empty fields waiting to be assigned something. I finally got to the point where I could drag a clone of this test program into another workspace. Hooray! But now, I need to move those cloned smart campaigns out of the test program into the program I intended for them to be used in. I can't seem to clone them into my destination program, and dragging them doesn't work. How can I accomplish this?
        • Re: Cloning smart campaigns to a different workspace
          Ashleigh Davis
          Anything you want to move between workspaces will need to be placed within a new folder - so simply clone and then place everything within that folder you'd like to move. You can then move the folder between the various workspaces.
          • Re: Cloning smart campaigns to a different workspace
            Josh Hill
            You should create a Program Template with all of the settings you use.

            Then you will have to place these in a Shared Folder to clone to the other WS.
            • Re: Cloning smart campaigns to a different workspace
              Nancy Casler (OG PROD)
              I know how this is SUPPOSED to work, and did set up a program template with all of the smart campaigns we repeatedly use. And it's all in a campaign folder (not sure what a "shared folder" is...) up in the default template. I cloned it right in the same default workspace so my original set of stuff would remain intact for future use. (I cannot cone it to another WS from the default workspace. Nothing in any of the other workspaces appears in the dropdown when I attempt that.) So I'm trying to drag my "transfer" campaign folder with the clone of my program template and its smart campaigns inside down into another WS. When I firist tried to do this it was giving me a mysterious error:

              "Rule is incomplete, 'Mailing ID is...' requires a value"

              I tried again, and did successfully it into another workspace (once), but just now deleted it and tried to drag it again to see if I could repeat the performance and got the above error again. ALSO, once I have it down into the workspace I need it to go in, I can't clone or move these smart campaigns into the program I want them to be in. The test program is next to the one I need those smart campaigns to go in, but I can't for the life of me get them to move inside. The "clone" option apears in the dropdown when I right-click on a smart campaign, but clicking on the word clone doesn't result in anything at all. I tried dragging the smart campaigns into my program, to no avail (red circle with slash). I've tried having the smart campaigns refer to specific emails and lists, but that only gets me errors when I try to drag the cloned program into another workspace. Is there any tutorial or documentation that specifically explians how this is supposed to work? I've read the article about it, but it doesn't work the way it explains. 

              Is there any possibility that there's something set in our Admin that is preventing this from working? I'm not the admin, and the admin person doesn't seem to know.
              • Re: Cloning smart campaigns to a different workspace
                Cheryl Chavez
                Hi Nancy,

                I would suggest contacting Marketo support.  There seems like there are some issues you hvae stumbled upon which are likely bugs.  Keep in mind that if the program or asset is referencing something that is not contained in the program you are trying to move, it will prevent you from moving it.  I am not familiar with the error message "Rule is incomplete..." but I'm guessing they system is looking for an asset it cannot find.

                Thanks,
                Cheryl