3 Replies Latest reply on Aug 29, 2014 12:57 PM by Josh Hill

    I set up a custom sync and now have no idea what's happening to my database.

      I signed up for a 10K Standard program, but have 30K records in SFDC.

      During my foundation course, I was told by Marketo reps that instead of setting up record types to limit what is synced to Marketo - I could simply create a custom field called "Sync to Marketo," check that box for all records I want to sync over, and then submit a support ticket to Marketo to create a custom sync.

      Done. Then... I find out from the support team that this was not the right path, and I should've set up record types.

      So, now I have 30K records synced to Marketo
      I also have 20K leads in Marketo with no email (missed checking off email on field level security)

      Sooooo....I don't really know what to do next, and I've been going back and forth on a Marketo support ticket. We're talking in circles really.

      At this point, my goal is to:

      1. Just sync everything over to Marketo
      2. Get rid of those leads with no emails
      3. Make sure this is set going forward....

      Can anyone here help?
        • Re: I set up a custom sync and now have no idea what's happening to my database.

               If you have enterprise edition of SFDC (I guess you do becuase you have record type) then personally I would always encourage managing this on the SFDC side with the use of sharing rules. The introduction of criteria based sharing rules in SFDC have made this a lot easier than it would have been a few years ago. The advantage here is that you are in control and can modify the rules at any time. With the sync filter on the Marketo side you will always have to reach out to support to make any changes.

               Let me respond to your goals (I am assuming that support have at this point put in place a sync filter based on the check box field.)
               1.  To get everything over you will need to ask support to remove the filter and then ask them to refresh the sync timestamp for the lead and contact objects. I'm not sure you actually need to do this, maybe you have left out a detail, but what will you gain from brinign all records over? Did the initial sync not pull over som records rthat you were expecting?

               2. You can create a campaign in Marketo 
               SMART LIST : email address is empty FLOW delete lead (delete in SFDC = false)

               3. To prevent leads with no email addresses in SFDC from coming back to MArketo you can create a criteria based sharing rule in SFDC so that your marketo sync user can only see records where email address is not = NULL. The steps for this are outlined in a video in the MArkeot university, It's the Admn SFDC #2 video.


                

          • Re: I set up a custom sync and now have no idea what's happening to my database.
            Hi Cathal,

            Thanks so much for your help.

                 I want to take the EASIEST route because as you can see I'm not a Marketo or SFDC expert.
                  
                 Would this work?
                  
                 1. Delete the "Sync to Marketo" field in SFDC for both leads and contacts
                 2. Delete ALL leads in Marketo, delete in SFDC=false
                 3. Resync everything over following these instructions.

                 I should expect to see 31K leads in Marketo when done, as that's how many are in my SFDC database.

                 Thanks.
            • Re: I set up a custom sync and now have no idea what's happening to my database.
              Josh Hill
              Ok, I think I see what may be going on.

              Support may have thought you wanted to block the sync FROM Marketo TO SFDC, in which case, the field value works well.

              But it sounds like you wanted Marketo to only SEE 10k records in your SFDC, blocking all of the others from syncing TO Marketo.

              So what you should do is this:
              1.           Do step 2 and 3 as Cathal suggests
              2.           ask your SFDC admin to tell the Marketo User to NOT see records with the checkbox=TRUE
              3.           in Marketo, run a Smart List where Checkbox=TRUE
              4.           Run Delete Lead, Delete in CRM=FALSE

              that should work. You may want to disable the Sync during this process depending on what else is going on.

              Otherwise I'd have to see your instance to understand what is going on here. feel free to reach out: josh@marketingrockstarguides.com
              1 of 1 people found this helpful