AnsweredAssumed Answered

Certain (earlier) smart campaigns in a workspace can view non-local assets, while others cannot?

Question asked by David Jackman on Feb 7, 2019

Hi all,

 

I wonder if anyone can crack this strange issue:

 

Our instance has a number of workspaces and partitions that were set up some months ago. We had an Operational folder with smart campaigns referencing local assets, and taking action on them, like Interesting Moments for particular form fill outs, etc.

We have since had our Marketo rep/team rebuild or clone (not sure which) those Operational programs from our Americas into our Global workspace, so we can track form fills, email clicks, etc. across workspaces. This has functioned and still functions totally fine.

 

What's strange is that now when I build an Operational channel from our Global workspace, and a smart campaign that references a particular form that lives in our Americas workspace (in Marketing Activities) in the smart list [filled out form - form name = "capabilities form..."], the red underline appears and says "Invalid Value for form name.. not found". I've tried refreshing, removing and re-adding, and even tried turning the trigger on anyway - tried as a trigger and a batch - still spawns the error. That wasn't odd to me at first, as I had simply thought that workspaces can only see assets that were built in said workspace. But then, I realized that our Operational programs that were re-built by Marketo/rep in the Global workspace does reference those outside assets without issue, and takes action on them. I experimented by cloning one of those smart campaigns, removed the name from the filter, then tried adding it back in, and discovered the same issue with my own build- that it now spawns an error. It's almost as if the form/asset names were grandfathered in to the smart campaigns when they were built, and modifying them makes it break.

 

Has anyone experienced a similar situation and figured out what is going on here?

 

Thanks for your help!

Outcomes