1 Reply Latest reply on Oct 30, 2018 8:48 PM by Veronica Holmes

    Can't delete field

    Bogdan Bujdea

      Hi everyone! I'm a developer and I'm having issues while trying to create a custom activity in Marketo. The setup goes like this:

      1. I give the client the details of the custom activity(name, fields, relations, etc.)

      2. The client defines that activity in the Admin with the details I provided

      3. I start creating custom activities in the client's Marketo account

       

      However, one of my clients said that his custom activities are not created, and I think I know why. One of the fields is called "Sender Email Address"(apiName is senderEmailAddress), but when the client typed the name for the first time he used an uppercase "M". Then he probably deleted the field and tried again, but it doesn't work because when I do the call to retrieve the custom activities this is what I get for that field:

      {

      ...

                          "name": "Sender EMail Address-Deleted-485",

                          "apiName": "senderEMailAddress-Deleted-485",

                          "dataType": "email"

                      },

                      {

                          "name": "Sender Email Address-Deleted-null",

                          "apiName": "senderEmailAddress-Deleted-null",

                          "dataType": "email"

                      }

      ...

      }

      Now the client even tried to delete the custom activity and add it again, but although in the UI he can see the correct name(just "senderEmailAddress" as apiName), in the API requests I get these two incorrect fields, so I can't create the activity because I need "senderEmailAddress" without those extra characters. Does anybody have any idea why is this happening? Thank you!

        • Re: Can't delete field
          Veronica Holmes

          Chances are Marketo is caching some info and it needs Support to help you fully get rid of it. I had a similar issue when deleting custom objects once, Marketo still thought the old object and fields were there so they couldn't then be recreated. Log a ticket and Support will help you out.