AnsweredAssumed Answered

token is getting cut off

Question asked by Jason Terrell on Oct 3, 2018
Latest reply on Oct 4, 2018 by Jason Terrell

I have a token on an email that is showing as cut off.

 

In salesforce, my custom object (I'll call it Sample) has a text field named MyField__c.  I have a second custom object named Sample2 with a field called Name.

 

In a token, I have the MyField being set like so:

 

#set($myField = $Sample.MyField__c)\

#set($lengthNumber = $Sample.MyField__c.length())

MyField: $myField

Length: $lengthField

 

In the salesforce data, the value for MyField on the record I'm testing is '12-34567-890' which is 12 characters long.

In the letter that is sent, the value comes out to be 12-34567-.

No matter what I do, it seems to limit the output to 9 characters.

 

I've tried adding an A to the start of the data for this record, removed the dashes, and tried it with other records.

 

I've refreshed the Salesforce schema in Marketo several times.


The field shows as text in the field list but I can't get any more data on it.

 

I've verified that it's the right letter and the right token, but changing both and seeing my changes reflected in the email I get.

 

This is very strange.  The field definition in Salesforce is text length of 12 and most records do not have data in this field.  But that shouldn't cause this to happen, should it?

 

Other tokens I have using this exact type of code (with other fields) work fine.  For example, on the Sample2 object, the Name field fully shows with much longer data.

 

Any suggestions?

Outcomes