2 Replies Latest reply on Jun 21, 2018 8:20 AM by Steve Lella

    Embedded Marketo Form Stuck on "Please Wait"

    Steve Lella

      Please note that this issue may or may not be related to my previous ticket: Marketo Landing Pages stuck on Please Wait

       

      I have embedded Marketo forms on various webpages. For example—This Page

       

      When a user tries to submit this embedded form, the form gets stuck on "Please Wait" and the Thank You page never appears. As was the case in my previous ticket, I had some antiquated javascript to track form fills in GA. I deleted that code, published the page, and unfortunately the page still gets stuck. I also cleaned up my GTM instance of extraneous tags, but no help either. The silver lining is that the form data properly posts to Marketo and SFDC.

       

      In case some tech bits are needed:

      • we tried this on a few different machines, all using Windows and on Chrome and Firefox browsers
      • this portion of our website is built on Drupal 7
      • one user was tethered into our network, and another user was using the VPN to connect to the network

       

      What could be causing embedded forms to send data but not show users our Thank You page? Any and all help would be greatly appreciated. Thank you!
      Steve

        • Re: Embedded Marketo Form Stuck on "Please Wait"
          Sanford Whiteman

          I filled out the form and was taken to the Thank You as expected:

           

           

          This works in Chrome 5x and Firefox 4x.

           

          Have you changed the config since you started this thread?

           

          What are the exact version of Chrome and Firefox in which you're repro'ing this?

           

          What could be causing embedded forms to send data but not show users our Thank You page?

          Aside from a broken onSuccess listener as noted in your other thread, you can have other listeners (like here you have a decorative onBeforeUnload listener on the window) which can readily mangle things. Certain ways of redirecting to non-SSL pages to SSL pages can also exit silently. But I don't see the symptoms here yet.

          1 of 1 people found this helpful
            • Re: Embedded Marketo Form Stuck on "Please Wait"
              Steve Lella

              Hi Sanford,

               

              Thanks for reviewing this thread as well. I didn't change anything since I started this thread. What I think happened is you saw a fresh version of the page without the onSuccess bit, and I was testing a cached version of the page (even in Incognito mode).

               

              I've since refreshed all caches, and voila! All my embedded & popup forms are functioning properly .

               

              Thank you so very much for all your help, Sanford.

              Steve