6 Replies Latest reply on Jun 20, 2018 12:31 PM by Sanford Whiteman

    Marketo Landing Pages stuck on Please Wait

    Steve Lella

      Hey Marketo.

       

      I recently inherited an existing instance of Marketo, as our resident Marketo expert resigned from our organization. During my initiation period, I realized some landing pages didn't have our Google Tag Manager code on it. I then went through every Marketo landing page we use, and updated the GTM codes across the board (both pages that were missing it and pages that already had it, but it was an older version of the GTM code). After I finished, we were collecting use behavior on all Marketo pages - victory! This was Friday the 15th of June.

       

      However, I noticed two unusual bits:

       

      1. Our forms are stuck on "please wait" and never show users a thank you page. However, all of the data does pass into Marketo & ultimately SFDC. You can try this for yourself on our newsletter subscriber page.
        1. What would be causing this issue?
        2. Any ideas on fixes?
      2. GA's event tracking stopped working.
        1. What would cause this issue?
        2. Is it related to the "please wait" issue?

       

      Here's the code that was on the subscriber page, and worked perfectly until Friday. We use this same bit of code, and just rename the eventLabel.

       

      <script language="javascript">
        MktoForms2.whenReady(function(form) {  
          form.onSuccess(function(vals, tyURL) {  
            ga('send', 'event', {  
              eventCategory: 'marketo',  
              eventAction: 'form-fill',  
              eventLabel: 'subscribe',  
              hitCallback: function() {  
                document.location.href = tyURL;  
              }  
            });  
            return false;  
          });  
        }); 
      </script>
      

       

      Being new to Marketo, I have no clue what to troubleshoot. Any and all ideas would be GREATLY appreciated!

       

      Cheers,

      Steve