2 Replies Latest reply on Jan 29, 2018 3:30 PM by Jonathan Yang

    Email script token using "if" not working

    Jonathan Yang

      I'm trying to display a extra line in an email if current customer is false and display nothing if current customer is true.

       

      This is the script token I have setup:

      #if(${lead.Current_Customer__c} == "False")<div style="font-family: Arial, sans-serif; font-size: 16px; color: #464646; line-height: 1.218em; margin-top: 5px;"><br /></div>

      <div><span style="font-family: arial,helvetica,sans-serif; font-size: 14px;">MESSAGE<br /><br /></span></div>#end

       

      In the email I have the token:

      {{my.if prospect:default=NULL}}

       

      I'm pretty sure I don't have this setup properly. So any help would be appreciated!

        • Re: Email script token using "if" not working
          Sanford Whiteman

          Please use syntax highlighting when posting code (in the Advanced Editor):

           

          https://nation.marketo.com/servlet/JiveServlet/downloadImage/2-180385-192444/pastedImage_2.png

           

          #if(${lead.Current_Customer__c} == "False")<div style="font-family: Arial, sans-serif; font-size: 16px; color: #464646; line-height: 1.218em; margin-top: 5px;"><br /></div>
          <div><span style="font-family: arial,helvetica,sans-serif; font-size: 14px;">MESSAGE<br /><br /></span></div>#end
          

           

          If Current_Customer__c is a Boolean, you don't check for "False" (definitely not with a capital F!).

           

          You check for the two string values "1" for true or "" (the empty string) for false.

           

          Also, don't use the :default= clause with Velocity tokens, use #if #else #end in the Velocity code itself.

          1 of 1 people found this helpful