3 Replies Latest reply on Jul 12, 2017 3:08 PM by Caleb Trecek

    Website Forms/Marketo/SFDC

      Hello,

       

      We are having issues getting our lead information in SFDC from our Marketo form on our website. We have successfully synced SFDC and Marketo and have reached out to our website provider for insight on this issue. When the form is filled out on the website, we are getting the follow up email, so we know flow is Marketo is set up and running. What are the common troubleshooting issues with this?

       

      Thank you!

        • Re: Website Forms/Marketo/SFDC
          Sanford Whiteman

          You should move your question to Products to continue ("Central" is for general marketing topics and this is Marketo-product-specific).

          • Re: Website Forms/Marketo/SFDC
            Veronica Holmes

            OK - starting ffrom the ground up...

            1) Are you using the Sync to SFDC flow step when a new lead is created? Leads don't automatically go to Salesforce once created, you need to push them there.

            2) Have you accidentally set the Marketo sync profile in SFDC up without create/write permissions to the lead object? That would usually throw an error in Marketo so that one would be pretty obvious if you've done it.

             

            I'd start there. If it's not those two things you should probably give us a screenshot of the sync to SFDC flow so we can help troubleshoot. Check the results tab in that syncing smart campaign and see if there's an error message.

            • Re: Website Forms/Marketo/SFDC
              Caleb Trecek

              HI Marielle,

               

              There are a couple areas I would start with in trying to identify the specific issue:

               

              • How are you controlling the sync of Marketo records to SFDC currently? A common misconception is that because you've established the sync, records will automatically flow between systems without issue. This is mostly true, but in the context of new records entering Marketo first, they do NOT automatically sync to SFDC unless you tell the system to do so.
                • This is done in one of two ways - the first being a smart campaign that has a 'sync to SFDC' flow step and is triggered as new leads are created in Marketo. The second is if you're utilizing the Marketo Program to SFDC Campaign sync, leads will sync to SFDC automatically as you add them as members of programs.
              • If you have the necessary pieces in place to sync the records as they are created, I would then suggest testing the form with dummy lead and then review the activity log to see what else might be occurring. From there, you should have the ability to see if the sync is failing and if so, for what reasons.

               

              I can throw out some other ideas if neither of the above do the trick, but those are the two most common ways I troubleshoot when working with clients who have similar problems. 9 times out of 10 you can review what IS or IS NOT happening in the activity log to get to an answer, so I tend to start there.