3 Replies Latest reply on Jun 20, 2017 5:49 PM by Justin Norris

    Custom Objects - Link field missing lead fields

    Jerry Yi

      I'm trying to setup a new custom object that would link to our lead/contacts on first and last name. Our lead/contacts all have first name and last name fields. But when trying to setup the link field, I can't seem to find those two fields in the list.

       

      Steps to reproduce:

      1. Create new custom object
      2. Create new field
      3. Set data type: link
      4. Set link object: lead
      5. Look under link field for first/Last name.

       

      Are there restrictions to link fields or am I missing something to allow links on first and last name? Unfortunately linking on email address isn't an option here.

        • Re: Custom Objects - Link field missing lead fields
          Justin Norris

          Jerry Yi

           

          Per the docs,

          If you choose lead, you'll see Id, email Address, and any custom fields in the list.

          Also,

          Only string field types are supported in the link field.

          So you'll need to either use the Marketo-assigned lead ID or create a new custom string field as your link. I would definitely recommend using the lead ID (which is guaranteed unique) instead of a field like first name or last name, which is not guaranteed to be unique and so is not suitable to be a link field.

           

          You could also create your own unique ID field as a string and populate with an ID from an external system if that works better.

           

          The main thing is that when you insert a custom object record, the link field needs to be populated with a unique primary key that will let Marketo know which lead record to attach it to.

           

          ---

          Justin Norris | Perkuto

            • Re: Custom Objects - Link field missing lead fields
              Jerry Yi

              Thanks for the doc link, but unfortunately I've read through it previously and wasn't much help in explaining why these two lead object fields are missing from the link field list for the "lead" link type.

               

              Screen Shot 2017-06-20 at 3.56.33 PM.pngScreen Shot 2017-06-20 at 3.56.19 PM.png

              Both fields are string types, and both a part of the lead object, but doesn't show up in the drop down menu when trying to select a Link field. Is my understanding incorrect and that first/last name are no considered a part of "any custom fields in the list." mentioned in the documentation?

               

              RE: linking to unique ids and fields. I agree is the better route, unfortunately it's not quite a option for us in this case. Our data lives separately (and in this case, incomplete) we were hoping to use Marketo to join our two data sources together while relying on less than ideal join criteria. Our custom object would be keyed off of first and last name combined.

               

              We're looking to supplement our contact records with the additional meta data in this new custom object, which is unique per first/last name. Joining that to our contacts is a many-to-one relationship unfortunately due to legacy dupes. But I can't seem to even get started without being able to link the custom object on first/last name.