13 Replies Latest reply on Mar 7, 2017 8:09 AM by Liliana Cheng

    Program Level sync to SF Campaign Insertion Failures?

    Adele Miller

      We sync the large majority of our Marketo Programs directly to SF campaigns through program actions.

      Usually this works well, but we have been finding pockets of data that hasn't synced when it was added to a Marketo Program and Marketo does not log this in the activity.

      The member is not resynced unless manually pushed.

       

      Has anyone else had this issue?

        • Re: Program Level sync to SF Campaign Insertion Failures?
          Kim Allen

          Hi Adele,

           

          The first thing I'd do is try to find similarities in these "trouble" leads. Look at their activity logs - look for anything that may straight out mention failure to sync xyz, to sync time (maybe it was a particular date and time), to fields that SFDC requires that these leads may be missing.

           

          Then depending on how you have this setup (flow step vs campaign/program setup sync) the behavior of not resyncing may be normal.

           

          Kim

            • Re: Program Level sync to SF Campaign Insertion Failures?
              Adele Miller

              Hi Kim,

               

              I am afraid there is nothing showing in their logs, it is like the sync to the campaign step has completely been skipped and nothing flagged.

              They are members of the top level synced Marketo program but are just not in the SF campaign.

              Strangely they are also syncing to SF as normal with no issues - just not in the campaign. So weird right?

               

              Thanks
              Adele

                • Re: Program Level sync to SF Campaign Insertion Failures?
                  Amanda Thomas

                  Hi Adele,

                   

                  We've had the same issue, and I couldn't find the problem either. (Probably just a coincidence.) I opened a ticket with support and it's still being worked on. I'll let you know the results, maybe they'll pertain to your issue.

                   

                  Amanda

                    • Re: Program Level sync to SF Campaign Insertion Failures?
                      Liliana Cheng

                      Hi Adele Miller and Amanda Thomas, I've been experiencing similar issues where some leads are not qualifying for triggers. I wonder if this is a bug that's more widespread?

                       

                      It doesn't seem to be isolated to any specific form or trigger in our instance. Of the leads who fail to qualify for a trigger immediately, the majority of them will later qualify for the trigger (anywhere from two hours later to four hours later). They start going through the triggers without any further action - meaning these leads will sit in Marketo doing nothing for two hours then suddenly go through the trigger they should have gone through two hours ago. So now, I have some leads who have gone through their triggers after a long delay and some leads still not qualifying for a trigger. What makes it more confusing is that most of my own test leads have made it through without issue.

                       

                      If it makes any difference, I first noticed this on 3/6/2017 around 1:50pm Eastern, but it subsided around 3pm, and picked up again around 7pm until 9pm Eastern. I've spoken to two different support reps who confirmed that the triggers are set up correctly and the leads should have qualified. They also confirmed that our trigger queue was minimal at the times I called in/specified. My ticket is waiting for a manager to investigate, but I'm getting impatient as I haven't heard anything from the manager.

                      1 of 1 people found this helpful
                • Re: Program Level sync to SF Campaign Insertion Failures?
                  Grégoire Michel

                  Hi Adele,

                   

                  This question probably belongs to products rather than to "marketing central".

                   

                  One of the first place to look at is to make sure that the SFDC campaign member statuses are exactly the same as the Program channel ones (down to upper case / lower case).

                   

                  -Greg

                    • Re: Program Level sync to SF Campaign Insertion Failures?
                      Adele Miller

                      Hi Greg


                      Ah thank you for the tip I have moved this now!

                       

                       

                      We sync the programs directly into SF campaigns and create the campaign using this insertion so the member statuses match exactly. The strange thing is - we do not get notified of the 'failure', no activity log recognition of the non insertion at all.
                      We only find out when a marketer checks their program and sees the different member numbers and we verify with a smart list.

                       

                      To get them matching we have to unlink the SF campaign sync in the Marketo program, use a flow step to force the missing people in and then resync the program.

                       

                      With us getting no notification we cannot see it en mass to do this to though, so we are worried it is a bigger issue than we think!

                       

                      Thanks!

                      Adele

                        • Re: Program Level sync to SF Campaign Insertion Failures?
                          Grégoire Michel

                          It can simply be a sync backlog. Support will be able to tell you.

                           

                          A few checks:

                          • Does this happens only to a few records or to all your program members?
                          • Try to add a dummy lead to the program as a member as see whether it shows in SFDC.
                          • Another test to run is to try to sync a lead (with a sync to SFDC flow step) and see whether this goes through in the activity log.

                           

                          If all this works as it should, you can also add these members to the program again. add them to a static list in the program. Then on them, run a "Change Program status -> Not in Program" (this will remove the lead from the program) then "Change Program status -> whatever status it was". And see if that syncs with SFDC. Furthermore, if this does not work, it will give you a good example to give to support for investigation (log the date and time you do it).

                           

                          -Greg

                          1 of 1 people found this helpful