1 Reply Latest reply on Dec 5, 2016 8:02 AM by Josh Hill

    Update record link, but information displayed is wrong

    Duane Kennerson

      Sorry, I didn't even really know how to title this question.

       

      Here is the situation:

       

      We send out emails to the people in our database asking them if they still want our updates and to unsubscribe or say yes and update the information we have on record for them by going to a Marketo landing page with a form to update certain fields stored in Marketo. The fields are set to pre-populate what we have stored in Marketo.

       

      Well of course some people just reply directly to the email typing out yes, they still want our updates without hitting the landing page. When this happens, our online sales counselors want to click the link for them and select yes on the landing page.

       

      However, the pre-populated information is not the information for the person the email was sent to.

       

      Ok, so I know just enough... to not understand...So the question is, why? I don't exactly know the flow here (from a Marketo stand point) or where the information is stored that the form pre-populates with, or how the update link works exactly because it looks like it's encrypting something in the link which I thought would tie to the individuals record but this does not seem to be the case.

       

      In my experiments, by clicking on the same exact link in multiple devices/browsers is that is might be stored in a cookie (but I cannot find the values in any stored cookies). On my desktop with Firefox, I get one persons information. Using chrome on the same computer, I get some old test values I used when testing forms, When I use my cell phone, I get values tied to me (not the person the email was sent to) that I must have used when using that phone for testing. The online sales counselors get someone totally different.

       

      Just trying to understand and have an explanation of why it happens.

       

      Thanks!

        • Re: Update record link, but information displayed is wrong
          Josh Hill

          There are several threads on this. You should NEVER have salesreps click on the links in replies from leads. What happens can depend on many settings

           

          • Link tags the sales reps as the Lead if they weren't cookied. Then what happens is the rep does stuff that scores the LEAD and it gets the behaviors all messed up.
          • Browser was tagged as the salesperson already and now the rep unsubscribed themselves.

           

          I recommend that on replies, the rep go into SFDC to make any changes.