6 Replies Latest reply on Aug 11, 2016 9:59 AM by Justin Cooperman

    Skeleton template help

    Josh Han

      Hi All,

       

      For the Skeleton template, when I put in a image from marketo into the two column module, it looks okay on desktop but when I open the email on mobile the image is stretched. I tried it with no style or having display: block; margin: auto; in the style field to center the image both look stretched on mobile, any help?

        • Re: Skeleton template help
          Justin Cooperman

          For all of our starter templates, you need to pick an image that is similar in size to the placeholder. If it is way off, you'll see this occur. This is due to a product limitation (it's not a template issue) that we'll be fixing in the next 1-2 months.

           

          For now, whenever you click "Edit" on an image element in a template, you'll be able to see the starting dimensions and just pick something that is a similar size (not just aspect ratio).

          • Re: Skeleton template help
            Jamie Lewis

            I always have to save my images at or near the same dimensions as the original for this to work.

              • Re: Skeleton template help
                Josh Han

                FYI I figure out a way that seems to work. The default skeleton template has built in image settings and its setting the width to 270px. If you change that to auto or your actual size within the Style field, it seems to work with any image size, you don't have to use an image that is the same size as the template.

                  • Re: Skeleton template help
                    Justin Cooperman

                    That's not true, as that won't work in different versions of Outlook. The real solution is the the "height" and "width" attributes on the <img> element itself must NOT be manipulated after an image is chosen. Unfortunately, due to this product limitation, whenever you select a new image these are overwritten.

                • Re: Skeleton template help
                  Ranvijay Singh

                  Hi,

                   

                  This usually happens when Image is given a fixed Height/width. But if the size is kept to be auto or it is given in percentages(%) instead of fixed pixels(px), then it will happen accordingly. This is not a Marketo issue at all but HTML/CSS thing.

                   

                  Thanks

                    • Re: Skeleton template help
                      Justin Cooperman

                      It is a Marketo issue, since we are overwriting height and width on the <img> element. The template says something like "width=270" and height isn't specified, but then when you choose a new image in the Email Editor, we override those values. This causes many issues, especially in versions of Outlook. You won't see the issue if you pick an image with the same exact size as the placeholder, since the dimensions would be identical to what they are expected to be.